Component Exception Error When Opening Grasshopper Script in Rhino.Inside

I have been working on this file for awhile now within Rhino.Inside and Revit. However, when I opened up the file today almost all the components received the component exception prompt like in the image attached. I was wondering if there are anyways to fix this issue. Thanks.

image

@prymal It seems like a very complex grasshopper definition so it is virtually impossible for me to figure out what went wrong. If you don’t mind create a small grasshopper definition that has the error and post here so I can replicate the error and debug

I get the same error every time I use Element Type Picker . I believe it is a component issue not a grasshopper definition problem.

My current work around is to use the Component Families Picker, run that into the Family Types component. It isn’t ideal but it works.

1 Like

Still not following what the exact issue is. “get the same error every time I use Element Type Picker” is not very clear. It’d be great if you can share the error message, example gh definition that causes the error, or some other method that helps me reproduce the error on my side.

Make sure you have the latest RIR as well. Mine is working fine:

Prymal posted the error above. Here is the error I receive. However, I just figured out right clicking ‘element type picker’ and changing the view to a check list resolves the problem. However, this is potentially takes up a lot more space than the default Drop Down List view. Seeing your video, it seems the version of RiR is different as the component looks different. WIll update and take a look again.

Update: I just updated the RiR and the issue still persists in Revit 2020 and Revit 2019. The ‘ElementType Picker’ does not appear as yours does, but is the same as my screen shot - empty box with yellow notice balloon. Here is my version info.

Rhino.Inside Revit: 0.0.7628.14366 (11/19/2020 07:58:52)

[Expanded Information]
Rhino: 7.0.20309.06003 (Rhino 7 BETA)
Revit: 2020.2 (20200826_1250(x64))
CLR: 4.0.30319.42000 (4.8.4250.0)
OS: Microsoft Windows NT 10.0.17763.0

Make sure to get the latest version of RIR. The Element Type Picker has been redesigned to to accept the source family name as well

I have just resolved the problem. The initial error message is gone but I believe it was occurring because the ElementType picker no longer works with CategoryTypes. I was required to use ModelCategoriesPicker. Looking at the help article on the ElementType component, it says Types are an allowed input - something to fix.

The second issue of the ElementTypePicker appearing as only a bubble is because I have Display/DrawFullNames disabled. When DrawFullNames is disabled, the ‘Family Name Here’ text is not generated and is replaced with ‘List’, which I think is the cause of the error that was mentioned above. Once DrawFullNames was enabled I saw the component as you did in your video. From a UX perspective, I think the component should have a left facing node and when DrawFullNames is off ‘FamilyNameHere’ should be visible.

I am getting a similar error. Every time I click on anything in Grasshopper inside Revit (Rhino.Inside) I get that same exception error. Doesn’t matter what component I click on in the Revit component menus (or any other normal Grasshopper components), I get image I then need to click the error’s OK button 4 o4 5 times to get it to go away. I have just installed the latest RIR and am running full Rhino 7. I see Rhino and Grasshopper in Revit but cannot do anything due to this persistent error. Any ideas what could be wrong? Thanks