Edges issue when trying to get a solid and Boolean not working

Hi,

I am modelling the Mercedes 300SL. After modelling the surfaces I joined the edges and I converted it into a solid. Everything was fine until I did the back wheels´ holes.


When I did these I tried making a hole by drawing a planar closed crv but didn´t make any hole. Then I tried other things such as extrude srf and then Boolean difference and didn´t work either. I finally got it when I did an extrusion of a srf and capped it and extracted some surfaces in order to split them. Now the problem is that the edges in these wheels join but don´t physically join. I have tried several ways to try and fix this but doesn’t work still, meaning that I can see through the car when zooming in (isn’t supposed to do that, I beleive) and exporting it to STL to 3D print it said that it created an open mesh.

Apart from this, another issue is that, when trying to do the doors details I project the line and then do a pipe. After doing the pipe I try to boolean difference and says that it fails. Any reason why it´s doing that? It does work in some cases but in others it doesn’t.

Please advice me on what I could do!mercedes_300SL.3dm (18.7 MB)

Thanks in advance!

@pascal

Your model does not have any naked edges. However the “Render mesh” setting in DocumentProperties > Mesh is set to the default “Jagged and faster”. The render mesh is used to create the display when surfaces are shaded, and can create the appearance of holes in the geometry. The solution is to adjust the Render mesh setting to refine the mesh.
https://wiki.mcneel.com/rhino/meshfaq
https://wiki.mcneel.com/rhino/meshsettings

How did you create the mesh for export to STL?

What do mean by “physically join”?

Hi David,

Thank you for the help.

By not physically joining is that they are ‘forced’. The images bellow show what I mean.


image

Any suggestions on how I could join these edges that seem to not be joined?

Thank you again!

Have you tried changing the mesh setting in DocumentProperties as I suggested above? The gaps between edges in your images appear to be gaps due to a coarse mesh, not a problem with the NURBS geometry.

The NURBS geometry is joined. If it was not joined ShowEdges with the Naked edges option would show naked edges. However too coarse a mesh can cause gaps or overlaps in the “render mesh” which is used to generate the display of shaded/rendered/etc surfaces.

I have tried setting the properties as you suggested and still says that it created an open mesh from a closed polysurface. Do you reckon this will affect when trying to 3D print?

Also, any advice on the boolean for the door details?

Which mesh are you referring to? How are you creating it? What is saying an open mesh is being created?

Hi @aliciaperezgomez97 - What mesh settings are you using to create the meshes? There seems to be 5 closed polysurfaces in the file. Using, for example, the settings in the screenshot below, results in 5 closed meshes. These should be fine for 3D printing.

Thank you Vanessa.

Are you saving as, exporting or which command are you using to create the polygon mesh?

It works now, thank you both!

What I´m still struggling with is the boolean as sometimes it works and others it does´t.

Use the _Mesh command to make meshes out of the polysurfaces.

Which parts are you trying to boolean? Do you want to union them, substract them?

Great thank you!

In the model you can see that I´ve drawn the outline of the windows, doors, etc.
The way I´ve done it is that I´ve created a closed crv to draw the outline of each door and window and then project it to the surface. Then I used the pipe command to then boolean difference it from the solid. It has worked in some cases but hasn’t in others and don’t know why.

The Boolean commands are essentially a combination of the Intersect, Trim (or Split and Delete) and Join commands. When the Boolean commands work they can be quicker and easier then using the individual commands, but as you have found the Boolean commands do not always work. A proficient modeler learns how to use the Intersect, Trim, Split and Join commands in addition to using the Boolean commands.

First step in determining why a Boolean command failed is to use Intersect and find the intersection curves between the objects. The intersection curves need to either be closed, or end on the edges of the surfaces to be trimmed or split.

If you want help with the Boolean problems you have described upload the parts of the geometry involved (including the pipes in this case) with the Boolean and describe the exact command you used and any options.

1 Like

https://drive.google.com/drive/folders/1peiNm4vLbAgOqWX3aHYuM6m7aQPbPOvz?usp=sharing
Hi David,

Please find attached the file including the geometry involved (the car and the pipes and patches which I´m not being able to join or substract to the main body). I have divided them in 3 layers: two of them are for the pipes that I’m not being able to boolean union (layer: Pipes not being able to join) and the other one for the pipes I’m not being able to substract (layer: Pipes not being able to substract); and the third one for the patches I haven’t been able to boolean union either.
For the pipes I have projected the curves onto the surface and then used the pipe command.
For the patches I first have drawn the curves and then project it. Then I used the loft command to create a surface following the shape of the car. The next step I´ve done is to draw the volume lines and patch these.
When the two different surfaces have been created I have joined the edges to create a solid.