DrawObject(RhinoObject, Transform) Not working


I’ve realized that the method DrawObject(RhinoObject rhinoObject, Transform xForm) is not working:

 DisplayPipeline.PostDrawObjects(object sender, DrawEventArgs e)
       e.Display.DrawObject(RhinoObject rhinoObject, Transform xForm);

Thanks and Best Regards

Any news about that?


Hi @dale, @brian and @stevebaer

After 2 weeks I’m going to assume that nobody is going to answer, and therefore it’s not going to be fixed, I’ll change the code to avoid using DrawObject function.

I understand that you have a lot of work with Rhino 6 Release, but it would have been nice to add it to the bug tracker, or at least answer the post, please if you’re going to fix it just make it known through any channel.

Kind Regards

@dale did you make a YT issue for this? I remember we were chatting about this issue right before I left for vacation, but am now having trouble finding the YT issue (or I forgot to make one)

Hi @stevebaer,

I probably never made one. But you can use this.


– D

I just tried calling DrawObject(RhinoObject, Transform) in the following way and things appear to be drawing correctly.

protected override Result RunCommand(RhinoDoc doc, RunMode mode)
  ObjRef obj;
  if(RhinoGet.GetOneObject("get", false, ObjectType.AnyObject, out obj) == Result.Success)
    DisplayPipeline.PostDrawObjects += (sender, e) =>
      e.Display.DrawObject(obj.Object(), Transform.Translation(10, 0, 0));
  return Result.Success;

Are you doing something different?

Hi @stevebaer

I tried using it in the latest release (6.0.17346.6021, 12/12/2017) and it’s working correctly, I assumed you had fixed it.

Great, this was probably fixed when we turned off some mesh caching code in RhinoCommon due to other bug reports. We will probably enable this feature again in the future once we determine the source of the bug, but that won’t be until at least SR1.