Does Archicad-Grasshopper connection work for rhino 7?

I have a free trial of rhino 7 but the archicad components do not seem to be on this grasshopper version. Does the Archicad-Grasshopper connection only work on rhino 5-6 currently?

Officially yes and there is a talk we will be getting Archicad 24 talking to Rhino 7.

But currently, I have installed Archicad 24 into Rhino 7 and works fine.

Hope this helps.


Copy the Archicad Connection .gha at the Rhino 6 plugins file to Rhino 7 plugins file. Same folder, version 7, should work. Works fine for me.

Hi Leonardo,
I have a silly question :roll_eyes:, since I am very new to grasshopper, where I find .gha file you are talking about?

Hi. To continue on Archicad, I see there is outdated tool like this Rhino-AC20 Connection with LCF (

Is there a way to export rhino geometries as native Archicad objects in native format?

This should help: AULA #44 ARCHICAD LIVE CONNECTION NO RHINO 7! - [PT/BR] - YouTube


Hi There Leonardo, i’ve tried your workaround for grasshopper/Rhino 7, copied the assemby file, but I don’t get it to work for me. What version of archicad did you use?

Make sure you get the correct plugins from Graphisoft and McNeel. Not some random guy.

AC24 & 25 opens .3dm as separate elements and layers nicely and 3DM to GDL plugin can be used as well.

Bom dia Leonardo,

I’m running AC24 - v7000
Rhino 7 fully up to date with Grasshopper Connection

I can’t set Archicad elements in GH. For example I click on set one beam in Archicad or set multiple beams in AC and then I go select beam in AC. Nothing sets in GH. Also have selected in AC first then tried to set in GH.

I used to be able to in Rhino 6 and AC24 - v3003.

I also tried AC25 - v4013 with Rhino 7 and correct GH plugins. Had to uninstall AC24 GH plugins to install AC25 GH plugins. Still no luck.

What versions are you running?

Archicad GH connections established and synched to the correct files. Am I missing something? Happy to admit user error at this point but I don’t think so.

Mac OS Monterrey with the last Intel chips before M1’s.

Thank you sir!