Disallow Join in AddBeam component

Hello, I have recently update to latest version of Rhino.Inside.Revit and the component AddBeam doesn’t work, it gives me the error:

  1. RhinoInside.Revit.GH: The input argument “familyInstance” of function Autodesk::Revit::Proxy::DB::Structure::StructuralFramingUtilsProxy::DisallowJoinAtEnd or one item in the collection is null at line 118 of file d:\ship\2020_px64\source\structural\structuraldbapi\gensrc\apistructuralutilitiesproxy.cpp.

I remember to toggle the “Disallow Join” option in previous releases of Rhino.Inside Revit, but not this time.

I cannot find any solution, any idea?

Hi Oscar, what build of RiR are you running.

Rhino.Inside Revit: 1.4.8053.19650 (2022-01-18T10:55:00)

Rhino: 7.15.22011.07001 (Rhino 7)
Revit: 2022.1 (
CLR: 4.0.30319.42000 (4.8.4420.0)
OS: Microsoft Windows NT 10.0.19042.0

I’m in that versions.

Is this the Disallow join you are referring to?

If you open up a new instance of Revit> new project and run this does it work?

Add Beam.gh (4.6 KB)

I’ve tried with the default beam it’s taking and it works, but same error with my beam:

INA-ENV_Canalon.rfa (360 KB)

Is this the Disallow join you are referring to?

It’s related, but not exactly what I mean, I’m trying to find an example of the option I’m talking about

What family template did you use to create that beam. It’s different than these two.


Other test I’ve done:
Add Beam Test.gh (5.9 KB)

Simple line, works with universal beam, but not with mine. Exploded polyline doesn’t work with any and gives same error

Generic Model - Line Based, maybe that’s the error? let me try again with structural framing template.

You were right, my family template is not right so when I use it, is not working as expected, even when manually I can place it.

Thank you very much, @Japhy

1 Like