Directshape not showing up in Revit

Hi guys,
as usual the issues I am experiencing with Rhino.Inside are might due to my inexperience in Revit.
I am modelling a sweep in rhino input it as brep and use ( i think ) the standar procedure to import the directspahe into revit. I am able to see the red GH preview (in Revit as well) but not the actual geometry in Revit. All looks correct, I am sure I am missing something very basic, but I have no clue. I think I used all the right components in gh, here a screenshot_:

last basic question are directshapes equivalent of Model-in-place category?

as usual thanks for your support

It appears to have been generated. Scale is a possibility, try selecting via this method or By Element ID (in the Manage Tab in revit) the id of your Element being 1336231

image

DirectShapes are Model-In-Place Elements, in this instance on the generic model category.

Hi Rickson, thanks for the reply!
it looks like as if it is not finding it, the scale looks right I am working in mm in the rhino.inside

grafik

are you in a 3D view?

yes!

I have just tried to repeat the procedure from a plan view, but no difference so far, can´t find the element.

as you can see vie the brep input in the grasshooper the geoemtry is visible…

Are you able to locate the element by ID?

That’s looks like a complex geometry, perhaps convert the arcs to straight lines and see if that brings something in, or just a straight run vs corners – in an effort to eliminate possibilities.

I’m still putting my money on scale tho.

all right, I actaully managed to find the element, which was indeed selectable with its ID.

you were almost there, except if for some reason the element was just shifted on Z axis…the strange thing was that it was shifted of exactly 23,3m which left me thing to some sort of error…


I thought it might have been becuse the geometry I am sending to the revit is not laying totally flat on one plane…But i have no idea.
I will keep modelling other element and let you know if I find the reason why it makes this shift

1 Like

I found out that the geometry once imported get projected on the origin plane…I am not sure why is that doing that, any idea?

The geometry needs to be placed on a level or workplane. Would you be able to share the Rhino geometry so I can test? :smiley:

I think that is the problem. Also the geoemtry should be constructed on an existing building which is modelled using model-in-place as well, so the sweep line i am using is not flat.

sure! do the brep in gh is enough or do you need as well the revit file, i guess? can I get an email address please?

Send in a direct message here on the forum :smiley:

Hi All- I had the same problem. It was touched on above, but wanted to clarify for anyone just arriving to the thread- the brep you are sending to Revit ‘arrives’ in Revit as a new construction element. So like me, if you’re beginning your project modeling existing conditions on a renovation project, make sure to create a new construction plan view, in addition to your demo view. Go to the new construction view, select it, and set to existing. It will now of course be in your demo plan.

McNeel- thank you for continuing to hone this fantastic product. Is there a way to change this, i.e. to control what phase the element is first set to when it appears in Revit?

Hi @Mike_,

We are introducing ‘Element Phase’ component in v1.2 to allow you to adjust the Creation and Demolition phase right after the component is created.

A complementary solution may be to create all the elements using the last Phase on the document by default instead of the Phase selected on the active view that may be arbitrary.

What do you think?

You can switch to “Daily Builds” channel from the Options dialog and test ‘Element Phase’ now if you like.

Keep in mind that files you save with a Daily Build version may not open on a previous version, so please do backups of your files.

1 Like

That sounds great. It would be nice to be able to switch the phase back and forth as demolished walls, doors etc often come back into scope during value engineering.

Thank you for the fast response. I will try the Daily Builds channel.