Default mouse wheel behaviour - walk instead of zoom

ui
rhino5

(eidam655) #1

Hi all,

One of my pet peeves about getting used to the Rhino interface is the mouse wheel zoom - you inadvertently end up with your “viewport camera” too close to the “viewport target” and further movement and rotation is very much slowed down.

Is there a setting, toggle, or a plugin, that would remap the mouse wheel scroll behaviour so that the “target” and the “camera” both move at the same time?

I know about WalkAbout, and that is actually what I would like to have. But I have problems with WalkAbout, as after rotating the view direction I cannot walk in that direction and I get reset (basically this http://v5.rhino3d.com/forum/topics/walkabout-movement-direction-not-changed-by-orbiting )

So if anyone had any idea how to solve either of these two problems, I would be grateful to you :slight_smile:


(John Brock) #2

In parallel projection viewports, Wheel Zooming pushes the camera target ahead of the camera.
In perspective projections viewports, the camera moves towards the target as you described.
If you press and hold the Alt key while wheel zooming in a Perspective viewport, the camera target point is pushed ahead like the parallel projection views.

If you turn on the “Camera” in the Perspective view, and try it, you’ll see the view frustum moving as I described.


#3

As John said, alt will push the camera and the target. If you want to look around like you do in Walkabout (pan the camera, keeping the camera location static), Ctrl + Alt + right mouse button.

Sam


(eidam655) #4

thank you, I somehow couldn’t google this on my own .) now is there any way I could change the stepping of the alt+wheel zoom?


(John Brock) #5

In Options > View, make the Zoom Scale Factor closer to 1.
0.9 is default. I like 0.95 better myself.
1.0 disables zooming completely.