Cumulative volume of meshes and srfs and polysrfs

In Rhinoscript, how can I get the cumulative volume of an array of objects, if the array can contain surfaces, polysurfaces, and meshes?

For Rhino 6/7, windows

  1. Check if they are closed.
  2. Start a cumulative sum (at 0)
  3. Loop through the objects.
  4. If surface or polysurface use SurfaceVolume() to get the object’s volume and add it to the cumulative volume sum
  5. If mesh, use MeshVolume()


Peter, good to see you here. Does this mean we may have an updated ‘Peter’s Tools’ soon?

Hi, my tools are up to date. You can get the latest here (though not much has changed other than compiling for Rhino 6/7.)

Great, mine haven’t been working for some time and I miss them. I don’t think I ever got the recompile for R6/7. Thanks!

Peter, I downloaded 1.98 which I believe is not longer a plug-in and just a list of Rhino Scripts but have not been able to get them to load. Any clues for one who is clueless about scripts.

Version 1.98 is a plugin. Does the .zip file you downloaded say 1.98?

Yes 1.98, I tried to install it by drag and drop and then by manually adding to the plug in’s folder as you suggested if the first doesn’t work. I then took note of something in your page about scripts and I guess that doesn’t work either. DOes this look right?


Looks loaded. In rhino, try typing BOM & see if Rhino recognizes it.

You can install the toolbar if you want to. It is in the same zip file.

I have installed the toolbar and invoked all of the commands include by clicking as well as typing into the command line an all result in a message that they are ‘unknown commands’.
Before bothering you further here. I did the rhp install once more and then also for the rui toolbar and took this screenshot in which it appears that everything is installed loaded and present but when I invoke any command nothing happens but at least no longer get the ‘unknown commands’ message.
I’ve been trying this for months without success but keep coming up short. I have used your tools ever since V5 (or maybe even V4) so maybe I will try the v7 install and let you know how that goes. I have not really moved into V7 for my production work but will try anyway.


Can you try holding Shift and Right-click on any tool in the toolbar, and send a screenshot of the dialog box?

Like so?

Here is another one of my favorites.

I read a suggestion in Discourse that I might want to try doing a repair on RhinoV6 so tried that to no avail.

Thanks for pursuing this!

J. Culbert 111
251-545-3664 251-550-9029 Cell

Huh, maybe RhinoScript is not functioning. Check in options in your plugins list & see if Rhinoscript is enabled. Also, I assume you tried restarting your computer?

Yeah, I think you found the issue. I looked and RhinoScript was not loaded so I checked the box and will restart Rhino and see what happens.

Thumbs up Peter! Thanks so much.

J. Culbert 111
251-545-3664 251-550-9029 Cell

1 Like