Compute server compilation error

The compute server is not compiling:

@will Plz help me solve this.

Do you get any compilation errors from Visual Studio?

I had the same issue and just fixed by downloading the .NET Framework 4.8 and restoring the missing dependencies on the project. :slight_smile:

1 Like

Yes, you are going to need .NET 4.8 as well as .NET 5 installed on your computer in order to compile all of the projects in the compute.rhino3d repository.

1 Like

A post was split to a new topic: Rhino Compute and Magnetizing FPG plug-in

Steve, how should this dependency be resolved?
I have both .NET 4.8 and .NET5.

I googled for “ResolvePackageDependencies task failed”. Some of the suggestions were.

  • Make sure you are using the latest version of Visual Studio
  • Delete the bin and obj directories and try rebuilding

I have tried both. Still no luck. Essentially when I run the application in the VS2019 debugger it stops at this line and throws exception.

Sorry to hear that. You must have had some luck as the image you show now is for debugging where the previous image looked like compilation/nuget package errors. or… maybe I’m confused as to exactly where you were seeing the previous error.

For this new image, it looks like Rhino is failing to initialize as a library. Have you run Rhino on this computer? If you have run Rhino on this computer, do you have any extra plug-ins installed?

The dependency issues got fixed once I switched to VS 2019 (because I have VS2017 as default)
Then the exception error was due to license issue. I had Rhino 7 and ran in few times (while on trial) ,but did not realise the trial had expired. I guess I should have checked that before testing compute , too bad my brain is running slow on the weekends :smiley: . It’s all resolved now. Thank Steve.

If you are updating the main Getting Started page soon(Running and Debugging Compute Locally with C#, VB) perhaps it’s worth mentioning minimum requirements such as .NET4.8 and .NET5 just to help new starters like me with troubleshooting.


Thanks for letting me know and happy to hear everything got resolved

I also have a problem with compiling the solution. Why is it giving me this error?

That looks like you are trying to start the debugger. Do you see any errors when you attempt to build the project?

Yep. Exeption,…

What is the entire error message?

The solution has two projects that need to be compiled to run

  • rhino.compute.exe
  • compute.geometry.exe

In the latest screenshot, you have rhino.compute.exe running and it is trying to find compute.geometry to launch.

Can you tell is the compute.geometry project is getting compiled?

If you rebuild all in Visual Studio, you should see output like the following in your output window

2>------ Rebuild All started: Project: rhino.compute, Configuration: Debug x64 ------
1>compute.geometry -> C:\dev\github\mcneel\compute.rhino3d\src\bin\Debug\compute.geometry\compute.geometry.exe
2>rhino.compute -> C:\dev\github\mcneel\compute.rhino3d\src\bin\Debug\rhino.compute\rhino.compute.dll
========== Rebuild All: 2 succeeded, 0 failed, 0 skipped ==========

As you may have understood, I have recently started studying C # and I am trying to get to know these tools: be patient, please

Go to the Build menu (Compilazione) and click on the first menu item which should be “Build Solution”. Once this step has completed, you can run the solution by clicking on the green arrow