Colibri exports Blank images

The Colibri 2.0 exports blank/black images. Any thoughts?


data.csv (91 Bytes)
Trial (13.1 KB)

Found the solution: Updating the graphic card works.

Kia ora.

This may be an issue for @DavidMans

I think I have another answer for you @Prethvi : I have downloaded and installed the new Colibri [Colibri | Food4Rhino]. And I have tried running the advanced sample file handily provided with it. Can you explain, is updating the graphics card, purchasing a new one, or updating the drivers?

It runs fine: however, as I have fallen into the habit of setting the view properties in the viewports to Rendered status it does not seem to work, producing white pictures. My focus of the Rendered view use is to produce nice graphs with white backgrounds that insert well into white page documents. In this mode, I get this set of white image files. However, if I set the viewport properties to have a white background in shaded mode, then I produce images as the file is set up to produce them.

I thought, for a moment magic! I have a solution for my Colibri issues. But no. I still have everything run as expected, but produce no images at all!

My issue still appears to happen: Colibri Images not being saved but data.csv file is produced? - #2 by MichaelDonn - honeybee - Ladybug Tools | Forum

But, I appear to perhaps be sidling up to a solution. It is not LadyBugTools, nor is it Colibri, it is probably something about Rhino and Grasshopper?

1 Like

Still working on the @DavidMans

I am speculating there may be a filename limit somewhere?

The data.csv file records the names, but no images are saved (this shows 2 of the 5 img files produced) .

This gets more and more weird.

I have simplified the colibri Iteration to one variable:



Now, it still randomly stops producing images, but it still produces all the calculated data.

In other words: 9 Variables (Cli_) each with 4 output numbers produced reliably. BUT, a subset of the images? The images are all named, but they do not all appear in the output folder. I am now more than ever convinced it is Colibri that I am not understanding. I did for a while think it might be the length of file and path name, but having tried this, apparently not.

Looking for advice @DavidMans , @Core, @enmerk4r

Hi @michael.donn! Sorry to hear that you’re having issues with the new Colibri. There are no restrictions on the length of filenames and, since the blank images do appear in the output directory, this isn’t a write access issue either.

A few questions to help diagnose this:

  1. Are you experiencing this issue with any other preview mode, such as Shaded, Wireframe, or Arctic?
  2. What kind of graphics card are you using?
  3. Have you tried using new preview components that are shipped with Colibri instead of the default Grasshopper preview?
  4. At what point in your definition are you placing the preview components? (In other words, how far upstream of the Aggregator)?

My hypothesis is that Colibri takes a snapshot of your viewport before Rhino’s display pipeline is done rendering the view. This is where the blank images come from. Raytraced views like Rendered or Arctic follow a different chain of events compared to Shaded viewports, so we did have some difficulties tapping into the new render pipeline. But there are a few things we can try

Kia ora @enmerk4r

Thank you so much for taking the time to understand this issue. It is that only a random number of images are being produced in the output directory. Often none are.

I had noted in exploring this, and when making sure that the answer was not elsewhere on the McNeel or Ladybug Tools community boards that an issue I had noticed with the LBT graphs was that they did not appear any longer in Rendered mode, but did appear in shaded mode. I can now reliably produce these images in print quality (without gridded or grey backgrounds).

However, the issue of random production of any pictures captured from named views is my issue. I have played with making the pixel size of the saved image exactly equal to or slightly smaller than the named view window. This seems to ensure that some images are produced, but not all, whereas if the dimensions in the Image Setting component are bigger than the named view window settings, then I think no image is produced.

My graphics card is an NVidia Quadro k1200.

I am not using ‘preview’ components, I am viewing graphs produced in the main directly by LBT graphing components.

Essentially, the Aggregator provides a set of settings, we wait 3-10 minutes while a bunch of three different energy simulations are run (Loads Balance, Temperature, and Energy Use), and then the input changes. When it has worked in the past, what is captured is the images in the windows just prior to the Aggregator changing the simulation inputs.

Hopefully this helps.


Hi @michael.donn m
Updating the driver from graphics card did the trick.

Thanks. That suggestion was really helpful. I did try it, but nothing improved. Odd. I presume you can view images saved from a rendered window.

Hi, @michael.donn

I stumbled upon a problem of missing images, but in my case is a delay in computing sun analysis after Colibri already aggregated images. You mentioned that Aggregator provides a set of settings where you can wait for all analyses to be computed before input change in Aggregator. Could you elaborate on what settings you are talking about? I think that could solve my problem!