CFD data update

I tried to simulate wind speed using the eddy3D( CFD plug-in), hoping to find the minimum UTCI and maximum average wind speed of the block model in the file, but every time I launched Wallace X, Wallacei kept changing the gene pool, but the wind speed had not been calculated, so there were a lot of calculation windows, but there were no valid results, and I tried to use data dam to wait for wind speed data to update, but Wallacei still ran as described above.0422.gh (487 KB)

@eddy3d may be best suited to help with this. I contacted Patrick from eddy about this a while back, and here is what he suggested (keep in mind though this was advice provided over a year ago and so there may be more up to date advice).

The challenge is to automate the Eddy process for Wallacei, the current process in Eddy is:

  1. clear cache (clean component)
  2. RunMesh (Simulation component)
  3. RunSim (Simulation Component)
  4. Run (Visualise Probes component)

To automate the above, Patrick recommends:
You could attach a “button” or “toggle” to all 4 components simultaneously and then should be executed in the right order which means you should end up with your probes at the end of this. Generally, a different approach would be to call the corresponding .bat files in the project folder. In the current version, there is unfortunately no way to do this with the probes but that could easily be added in a future version.

(again, this communication is from Jan 2020, so there may be more up to date info).

1 Like