Can't trim a small Srf tip

Here where fillets fails, I’m rounding the connections with : DupEdge > Pipe 0.1> Trim > Then BlendCrv to round the sharp tip, so BlendSrf will manage to take that corner.
that timing worked fine on the same same near by [see image]
but it refuses to trim on these 4 places.

I tried shrinking the Srf, looking at the CP to try to understand the problem, also making a Srf from the green trimming Crv and extending … but I can’t seems to solve this one.

Trimming issue 12-07-2020_V6.3dm (161.3 KB)

thanks a lot

Hi Akash -… nothing in the file but 8 curves…?


Sorry @pascal I didn’t check that all the layers were copied correctly
here’s with the Srf
Trimming issue 12-07-2020_V6.3dm (361.8 KB)

thanks a lot

Hm - I can only imagine this is because the edge is continuous there where it crosses itself - can you post or send me the object before the edges are created and tell me how to reproduce this?


added the Srf before the pipe trim. [TeraCota shade layer]
and the pipes [green layer]
Grey layer show the problem as before .
Trimming issue 12-07-2020_V6.3dm (7.9 MB)
Thanks a lot

Hi Akash - the way out is to intersect the pipe and the surface, clean up the self-intersection with the small green blend, then trim the surface. It fails to trim now, (my guess) because the edges cross and it cannot figure out what bit to remove. But I do not know if that edge situation should be allowed to occur - I will ask a bigger brain.


Thanks Pascal
I will try as you suggest
Just to note that the other 4 Hearts that were already successfully trimmed also had that crossing end of the edges.


Hi Akash - thanks, hm - yes, I see that some can be trimmed… I don’t know, but I’ll ask a developer to have a look.


Using intersect solved the problem very nicely.
thanks a lot.

I learned here that it would have been a better approach for all these trims. Much better to intersect then trying to aim for trimming correctly inside that little pipe, obscured by other geometry all around.

Edit: actually revisiting my above statement, I now see that in some places, _Intersect curves will not trim, and in those places, using the pipe and carefully aiming inside of it does work.

With best regards

For what it’s worth: “splitedge” at the ends of the green curve and than “replaceedge” with option “select curve” works perfectly fine to solve your problem.

Thank you, @norbert_geelen
Learning another method here. _ReplaceEdge .
I fiddled with it a bit in the past, [without properly reading about it in Help… which I have now]

with best regards