Can't see geometry preview, but able to bake geometry. Select baked geometry, preview shows up

Really odd behavior just started. I can’t preview the geometry in Rhino, it was working an hour ago. I’ve done something, but I don’t know what. I have preview turned on. If I bake the geometry and select a part of the baked geometry the geometry preview becomes visible.

any help would be appreciated. thanks.

Rhino 5, Grasshopper 0.9.0076 with plug-ins Wb, Kangaroo, LunchBox, LMNts, Windows 10

Weird. Just closed both Rhino and grasshopper, re-opened and it’s working again.


Glad that turning-it-off-and-turning-it-back-on-again worked. If it happens again or if you can repeat it let us know how. It’s possible one of the objects that was being previewed got into an invalid state causing the rest of the preview to be short-circuited.


I have the same problem. I have restarted Rhino and GH but it is still not working.

Which rhino mode ?
Did you use custom preview ?
If yes right click on it and see if render is selected