Can't load my components when debugging

I was following Your First Component tutorial, but when I debug the project, I don’t get this dialog

so Grasshopper doesn’t load my component. I repeated the whole tutorial again, and tried with Rhino 6 and Rhino 7, but it was the same.

When I manually drag the .gha in the bin directory file to Grasshopper window, it moves it to the Libraries folder, and it works, but I can’t find how to make it load it automatically.

Can anyone tell me if I can configure the library folders anywhere else or how I can make that dialog show on debugging?

Are you sure you don’t need the extra debug folder?
check the build output

Thanks for answering. This is the build output:

There is no Debug folder as in your output. Do you know why is that?

Several years ago, I was following the same tutorial and I did exactly as it says (like this time), and I remember the debugging was successful, so I don’t know why this time it doesn’t, so I don’t know what’s happening.

The folder listed there does not match your project folder.
should be set to match the part up to bin.
I’m guessing you are building somewhere else.

Sorry, I have not much experience with Visual Studio, and I don’t know if I understand what you’re saying, becuse HelloGrasshopper is my projet folder. You mean the path D:\Documentos\repos\HelloGrasshopper in the build output should be C:\dev? I’m confused.

I’m using D: because I have Windows installed in SSD C:, and my files in HDD C: , I don’t know if that has anything to do with anything.

If it helps, my project folder structure is the following:

  • D:\Documentos\repos\HelloGrasshopper
    • bin
      • HelloGrasshopper.gha
      • HelloGrasshopper.pdb
    • obj
      • Debug
        • TempPE (empty folder)
        • .NETFramework,Version=v4.5.AssemblyAttributes.cs
        • DesignTimeResolveAssemblyReferences.cache
        • DesignTimeResolveAssemblyReferencesInput.cache
        • HelloGrasshopper.csproj.CoreCompileInputs.cache
        • HelloGrasshopper.csproj.FileListAbsolute.txt
        • HelloGrasshopper.csprojAssemblyReference.cache
        • HelloGrasshopper.dll
        • HelloGrasshopper.pdb
    • Properties
      • AssemblyInfo.cs
    • HelloGrasshopper.csproj
    • HelloGrasshopper.sln
    • HelloGrasshopperComponent.cs
    • HelloGrasshopperInfo.cs

As in the reference on the grasshopper developer settings needs to be set to:

You get the dialog by going into Rhino and running the command grasshopperDeveloperSettings

I found this answer and he says to run _GrasshopperDeveloperSettings to show the dialog where I have to specify the bin of my project where the .gha is. Now it works. Thanks for answering.