Can't hide/remove line from a closed polysurface

I have a closed polysurface that I’ve booleanunion’ed and then ran a mergeallfaces to get ride of the intersecting lines. But this one stubborn line won’t go away. I know I can explode the object and delete the line, but I want the whole thing to remain a solid. Is there some commands or processes I can run to get rid of it? Alternative solutions? Thank you.


It looks like two joined surfaces in the image but we would need the file to be sure. Sine you don’t have isocurves displayed, it’s even harder to tell.

BTW - Booleans do not “Merge” or simplify surfaces.

MergeAllFaces which you said you ran will merge coplanar, adjoining faces. Check to that the two faces with the line between them are exactly co-planar.

Thanks guys. It was two solids which I booleanunion’ed, then mergeallfaces. How do I determine if they’re not co-planar?

1 Like

If I had the file, I would extract the two surfaces from the polysurfaces and try MergeSrf.

Hi John. I managed to extract the two surfaces, but even then, the line is still there in the original spot and when I select it, it selects the entire object. I tried mergesrf as suggested and it did remove the line from the surface, but when I replaced it over the opening of the object, the line reappeared. hmm… It’s a big file so sharing it doesnt quite work efficiently. Plus I believe I have to learn this by doing and asking, rather than having someone do it for me. Thank you.

Making guesses based on images and comments is inadequate and frustrating.
We’re not going to fix your file for you.

If you post your file, we can figure out what the issue is and guide you through fixing it yourself.

If you can’t or won’t then your best bet is to concentrate on tutorials.

THanks John. I understand.

Not meaning to be rude, but you will learn something from this by re-modelling it to avoid the join in the first place. Model the parts to be booleaned so that the surfaces either side of the kink are planar from the beginning. Sometimes it is actually quicker to re-model in rhino rather than fix.

Having said that, you might be able to subobject select an edge or face and move it to create planarity between those two surfaces.

SolidPtOn and SetPt would be one way to make the faces coplanar, assuming they are intended to be parallel to a construction plane. Or set a construction plane to one of the faces and then use SolidPtOn and SetPt.

Thanks guys. I tried sub-object select and the solidpton with setpt, but not sure how to use these with the model. I managed to boolean union everything but after running mergeallfaces, there are still lines that remain. I’m at the extent of my experience and can’t figure this out. Can someone please have a look at the model and tell me what I must do to remove the lines from the faces? Thank you. marble.3dm (161.2 KB)

marble-2.3dm (120.1 KB)

is this what you needed…?
there were lots of surfaces out of place, maybe easier to rebuild, but basically extending surfaces with sub-object select and trimming is how i went about it, with _ShowEdges on to see the naked edges.

I’d be happy to learn a quicker way if someone else wishes to suggest.

with best regards

Thank you Akash. That helps. Im going to try your technique.

Options-> View-> Display Modes -> Shaded

Uncheck “Show isocurves”

That should do it?

Update: I tested it on an extruded solid rectangle on which a Boolean split was applied. The lines go away when isocurves are unchecked

It’s not an isocurve.

I looked at your file. If you simply want to get rid of that line, which is an edge of two surfaces meeting. You can simply extract and delete them then use the “Cap” command. It will automatically close any planar closed boundary polysurfaces.

The file you posted has lots of extra geometry in it that the original picture does not have, and has some other problems you need to address, but the above will solve your current question.

Rhino has lots of little issues you become a custom to working around. Like this exact example of MergeAllFaces not working at all but cap will…


1 Like