"Cannot find area" Issue with Rhino Curves

Suddenly having this issue in some files I am working in where the Area command cannot calculate the area of closed, planar curves, and can only find the area if I make a surface from the curves (Which I do not want to have to do)

  • All my curves are planar, closed, non-self intersecting
    -Even if I re-draw the curves manually, it still cannot find the area
  • My units are feet, precision is set to 0.0001 for everything.
  • The objects I am trying to find the area for are not very small, not extremely big, all about 1800-2000sf.

I’ve tried projecting to C Plane, that does nothing. I’ve tried copying to a new file, tried changing units, tried everything I can think of. Again, it works if I make a surface from the curves. Also not complicated curves - all rectilinear shapes.

Thanks in advance!


I don’t believe curves have area. If you want to measure the area of something it needs to have area - like a plane or surface. You are right to make a surface from the enclosing curve.

Hmm, it can do the area of just closed curves.

So we’d need to see an example of a curve that doesn’t work…

Closed curves should work fine unless they have microloops in them.
CurvatureGraph will quickly find loops.

1 Like

This is a known bug which has been fixed in the current 7.18 release candidate.

OK, awesome, I’ll check for a latest update and try to update. thanks so much, hopefully this works.

Here is an example of a curve.