Cannot cut with cutting plane

Why is this seemingly simple task failing???
I’ve tried also to trim and split with a curve, and then another curve expressly drawn to use for cutting. (161.3 KB)

Some funny stuff going on at the top of your surface… First run Intersect on the two surfaces - notice that the curve does not go all the way to the end of the surface (flat end). Undo that, then turn on control points for the warped surface. Look at the 5th-6th rows in V. There are control points stacked almost on top of each other near the middle. It’s like a micro fold in the surface at that point. Rhino doesn’t like that very much it seems…

A couple of ways to fix it, I selected the two stacked points in the middle and the two sets of two on either side, and I ran Smooth with the default settings, that fixed it well enough to split. You can also Smooth the whole surface, that works as well…

Otherwise maybe look at your input curves and surface creation method and see how it can be made smoother.


Your method did the trick. I’m wondering however did the problem arise in the first place. The object was made from a network of curves and then rebuilt. I suspect the problem was created in the rebuild. It’s unexpected to have such issues while proceeding with what I suppose are best practices.

I would be surprised if this was caused by Rebuild alone. Usually Rebuild will have a tendency to smooth out and uniformize the point structure, not tie it in knots. However if you have an exact “recipe” for re-creating the surface, it would be good to look at.

“Best practices” are not a hard and fast set of rules to be followed, they are based on experience and differ from case to case. Some people will tell you to “never use this command” or “always use that command”, but the truth is they all have their uses in a given situation.