Can anyone help me with offsetting the surface? (file included)


(Iparapakk) #1

i want to offset the surface but there’s just a little glitch that annoyed me, but the weird thing is that the result is closed polysurface. i tried shell but didn’t work.


(Iparapakk) #2

offsetcurve.3dm (8.2 MB)


(David Cockey) #3

The file you uploaded has individual surfaces, and a polysurface corresponding to each surface. Is there a reason you have not joined the surfaces into a single polysurface.

I assume you used OffsetSrf which has an option, Solid. If Solid=Yes the result is a closed polysurface.

Is the “glitch” the parts protruding near the ends? If so they are caused by the offset distance being greater than the minimum radius of curvature and offset to the inside.


(Iparapakk) #4

so what do i do? i tried to lower the distance of the offset but same thing happen


(Pascal Golay) #5

Hello - you’ll need to make the offset smaller than the smallest radius of curvature of the surface. You can get a idea of the number using the Curvaature command , clicking in the most highly curved areas and making a note of the maximum curvature reported on the command line - the radius of curvature will be the 1/curvature at that location.

-Pascal