(Bug) Intersect Surface Surface does not find point


intersectionbug_v8_2023-10-19.3dm (3.4 MB)

surface surface intersection does not find points

to repeat - attached file and:

intersecting a sphere and a trimmed 5-sided surface → no result

intersect the curve and the sphere → 5 points

(not in the file)
_offsetSrf inwards by 0.001
_intersect 5-sided surface with new Sphere → 5 small curves

same behaviour for the 2 squares.

I really think - stuff like this should work, before V8 is released

there are other topics that are maybe related

another fail of intersect.
_intersect the green dices - no result

do some testing with edges / additional curves → the boxes share exactly one point, far beyond document Tolerance.

intersect_bug_v8_dices.3dm (3.1 MB)

any chance this topic gets some attention ? thanks

I tried in Rhino 6, 7 and 8 but neither will give me intersections, did this ever work on your end?

not sure.
(I would guess yes it worked, but don t want to claim it)

but it should. - don t you think ?

I guess it makes sense, the reason I asked if it ever worked is because you said ‘should work before Rhino 8 is released’, which made me think this got broken.

Apparently I have never ran into a situation where this was an issue, but I agree it is cleaner if point intersections are found.

RH-78423 Intersect does not detect point intersection

Hi guys,

You made me curious so I wanted to test this out with a scripted RhinoCommon function. Because you see, the method Intersection.BrepBrep() is supposed to return points (if there are any found).


But it never does in any of my tests in 6, 7 or 8. So if the RhinoCommon method fails, I assume the underlying method it is calling is what is failing, which is why Rhino’s native Intersect command also fails at this.

I added a comment to this effect to the youtrack item.