Bug in region union grasshopper 1...rhino6

hi error and bug in region union in xz or yz or… planer curve in grasshopper 1…rhino6

bug rhino6.gh (11.6 KB)

It works well here. It mighe be related to the relative tolerance of your document.

I ran into the same issue. Here in V6 I get errors:

Same geometry in V5 works:

180601 V6 Region Union.gh (12.3 KB)
180601 V5 Region Union.gh (10.9 KB)

@DavidRutten I’m sure you have enough going on to keep you busy but should I assume this has been logged? Or is it only logged if you post here that it has been logged?

I have exactly the same issue on Region Union’s throughout my gh document in Rhino6, which all worked fine in v5. Each time the warning balloon states “X empty regions were ignored”. I’ve changed the absolute tolerance in Rhino to 0.1mm and updated to the latest version (6.6.18168.12081, 06/17/2018 // 1.0.0006) to try and fix the problem but it hasn’t made any difference. It would be good to know if this was known bug and whether there is a fix expected anytime soon. Many thanks

Here are the some examples of the Region Union error happening in V6, whilst working perfectly in V5 as well as an attempt at a work around which has got the better of me! Region Union V5 working.gh (59.2 KB)
Region Union V6 problem.gh (59.3 KB)


Is this bug logged ?

I have no idea. But if I open the files above here, it seems like both mine and Mattm’s file do work now in rhino 6. So I assume this has been worked on. If you have a file where it’s not working on I suggest posting it here.


Here is some error case :

  • 2 circles
  • 1 rectangle
    => The Region union of this 3 geometries produces a geometry with some imprecisions.

bug region union.gh (9.7 KB)

I’m not seeing that here with your file.

GH union in blue, RH union in green, input geometry in red.

What is your document tolerance set to? I have mine at 0.001.
If I change the linear resolution of the dimensions to fall below that document tolerance, it will show fuzziness, but that is to be expected.

1 Like