Bug - Curve offset with Corners=None and Caps

When using Offset command with Corners = None and a cap option (round or flat), display shows the caps at the ends, but when clicked, they aren’t created.

It shoudl either accept and create the caps, or the option is absurd and therefore it should disappear from the command line.

R7 and RWIP.

Hi Magic -

I’ve put this on the list as RH-76297 Offset: Create caps when caps are requested
I take it that you expect the result to be as what is shown in the preview, and not two closed rectangles?

1 Like

Hmmm… I haven’t thought of that. I guess if I want closed rectangles I’ll do the offset for each segment, to be sure anyway.
If this specific option creates caps for each segment, then the next logical thing you’ll put on the pile is offset for multiple curves at once :sweat_smile:

But then you’d first have to tell me what’s wrong with the OffsetMultiple command…

1 Like

Incredible !
I never paid attention to the plural in the prompt. I thought this was for offsetting one curve multiple times (which it is, partially).

Now I immediately have a suggestion.

If you preselect some curves and run Pipe, it will automatically run with the Multiple option. Is there a way that if several curves are selected, Offset could run OffsetMultiple instead ?

Mitch added that request: RH-68741 Offset to allow multiple curve selection