Boolean difference either failing or completely surface of a solid

Hi! Posted this earlier but I completely changed the model to fix it. Neither of the long strips of Latin are able to be boolean differenced from the main body without either throwing a boolean failed error or completely deleting the interior of the ring. It was working perfectly before until I replaced the original text with a bold version.
Any help is appreciated :slight_smile:
File: Example.3dm (18.0 MB)

Generally speaking, you will need to verify the outline curves created with any font before using them for modeling.
The reason is Rhino is using fonts in a way they were never intended. Rhino needs clean geometry. Fonts do not.

Closely inspect the curves created with your chosen font.
There may be gaps, zigzags, etc.
Most of the time, using the Curve Boolean command will quickly cleanup a messy curve.

1 Like

Hello - one thing you need to watch - in addition to the caveat from JB, is that FlowAlongSrf, assuming that is what was used here, is not an exact operation - it’s pretty good, but it involves some refitting of surfaces - What I see here is that there are a few places where the surfaces overlap themselves in the area where they interesect the ring and this is probably causing the problem.

Having good curves, which Font curves never are, will help but I woul also try to minimize the taper or distortion by placing the objects as close as possible, in depth, to the location where they will intersect the ring and make them just the depth required, plus a hair. You can test individual objects, rather than groups, too, if you get a failure since one miss will stop the whole operation.


1 Like

I’ve tried using Curve Boolean on all my fonts before extruding but it doesn’t seem to make a difference. It must be something about the font though if it works with the normal version but not the bold right?

I’m doing some troubleshooting and I think it’s just the bold version of the lowercase E in Crimson that doesn’t work correctly. I’ll try and rebuild the letter and see if that works.

Rebuilding the E curve worked yay!!! Thanks for your help that was driving me nuts :slight_smile: