boncySolver not working


I want to use bouncy solver for a specific task (ball falling on a flat surface) but it seems that the tool is not showing any change or movement
in my geometry. I have connected the other tools correctly ( we have been given an exact assignment) so I don’t know where to look for this problem. Have any of you had such a problem?

Hi @Helena2
Without the definition it’s impossible to say where the issue is.

Here are the problems:

The Toggle and Button are connected the wrong way round - the ‘On’ input is like a switch, so you want an input that stays true for it to run. Reset is something you press once to return the simulation to the start, so you use a button there.

The Collider input is not connected. In Grasshopper you need to hold down shift to connect multiple wires to one input.

The ‘W’ input to the ‘Load’ component should not be negative. There’s actually no need to use this input at all in most cases - the default of 1 is fine. Adjust the speed it falls at by changing the ‘F’ input of the Z vector component.

1 Like

thank you that worked! The surface is still not recognized as solid because the ball is going through it and it does not matter what kind of value I put for the speed, it remains unchanged

Again, without the definition I can’t see where you’re going wrong (10.2 KB)

Okay, so there you’ve added also a large sideways force. This doesn’t make sense for a falling ball, as it is a constant force, so like a sideways gravity.
Removing that, a value of somewhere between 0.1 and 0.01 works for the vertical load.

1 Like