BlockMesh / SnappyHexMesh Error Running own model - Butterfly Outdoor

Hello all,

I’m a beginner for grasshopper and am trying to run some CFD using the butterfly plugin. I’ve managed to successfully carried through the Outdoor and Indoor CFD tutorials and viewing the results on paraview. I’ve tried using my own model (imported from sketchup) but am running into problems during the Meshing section with the following errors:

  1. Solution exception:
    –> snappyHexMesh Failed!
    Cannot find file “points” in directory “polyMesh” in times 0 down to constant

    From function Foam::word Foam::Time::findInstance(const Foam::fileName&, const Foam::word&, Foam::IOobject::readOption, const Foam::word&) const
    in file db/Time/findInstance.C at line 202.

FOAM exiting
[0] (553.8 KB)
ProjectPlan.3dm (4.2 MB)

[0] snappyHexMesh: cannot open case directory “/home/ofuser/workingDir/butterfly/Project1/processor0”
FOAM parallel run exiting
#0 Foam::error::printStack(Foam::Ostream&) in “/opt/OpenFOAM/OpenFOAM-v1612+/platforms/linux64GccDPInt32Opt/lib/”
#1 Foam::sigSegv::sigHandler(int) in “/opt/OpenFOAM/OpenFOAM-v1612+/platforms/linux64GccDPInt32Opt/lib/”
#2 ? in “/lib64/”
#3 ? in “/opt/OpenFOAM/OpenFOAM-v1612+/platforms/linux64GccDPInt32Opt/bin/reconstructParMesh”
#4 ? in “/opt/OpenFOAM/OpenFOAM-v1612+/platforms/linux64GccDPInt32Opt/bin/reconstructParMesh”
#5 __libc_start_main in “/lib64/”
#6 ? in “/opt/OpenFOAM/OpenFOAM-v1612+/platforms/linux64GccDPInt32Opt/bin/reconstructParMesh”
rm: cannot remove `proc*’: No such file or directory

When I run the BlockMesh component, it created a case in my running folder but inside the folders of 0, constant/polymesh are all empty.

Any feedback would be greatly appreciated. Thank you.

You are likely to get more support for issue concerning Butterfly (Ladybug / Honeybee) over on ‘the other’ discourse:

Hi, I met the same problem. Have you find any solution to solve it?:sob:

Hi - you really need to check the LB|HB forum here: