BlockEdit is screwing blocks up


#1

(6.0.16320.11371)
When opening up blocks with Blockedit, some sub-blocks get shifted away by some translation vector for no reason…


(Brian James) #2

Can you share that file with me privately or email it to tech@mcneel.com please? Or post it here if it’s not private. Thanks.


(Brian James) #4

Continuing on tech


#5

(6.0.16341.12271, 06/12/2016)

Blocks are still a mess.


(Pascal Golay) #6

HI Olivier - as always, if you can post or send me the misbehaving file(s) that would help a lot - thanks.

-Pascal


#8

i noticed the same issue today, thought it had to do with the blocks originally coming from sketchup.
these are nasty sometimes.

Pascal i sent you the .skp that makes trouble after importing to v6.


(Pascal Golay) #9

Yep- thanks guys- I see the problem in both files.

-Pascal


(Steve Baer) #10

@pascal, are you seeing this problem in the latest build?


(Pascal Golay) #11

@stevebaer yes, I see it in a build from this morning. I’ll make a YT item in a moment… just checking the build o the moment.

-Pascal


#12

Please, make blocks great again !

Still not working in 6.0.16355.12241, 20/12/2016


#13

Still not working in 6.0.17010.13211, 10/01/2017


#14

Yeah this was doing the same for me the other day. It was intermittent though.

There also seems to be an intermittent freeze while working ‘inside’ the instance. Sometimes it’s not possible to save and move back to the main model space. You have to click on the X and close the editor window and start again.

It’s not something I could replicate with a set of given actions.

Andy


#15

im having this same issue, also with nested blocks. any fix?


#16

Still not working in Work In Decline
(6.0.17024.22391, 24/01/2017)


#17

Still a mess in WIP 6.0.17031.12411, 31/01/2017


#20

Blocks mess test.3dm (65.1 KB)
The problem seems to come from a bad handling of the rotational component of transforms in nested blocks.
In the above file, the baseline blocks are made into nested blocks :
-The first nested block is made from copying the baseline blocks with a horizontal translation.
-The second nested block is made from copying the baseline blocks with a “diagonal” translation.
-The third nested block is made from copying the baseline blocks with a “diagonal” translation and rotations

Only the third nested block exhibits the wonky behavior when edited.

Wakey wakey folks !


#21

Management of blocks in 6.0.17052.4301, 21/02/2017


#23

No progress whatsoever in 6.0.17066.12281, 07/03/2017


(Pascal Golay) #24

Hi Olivier - this was the block that used to spread itself out all over the place, right?

As far as I can see this file works now. I guess that is not the case for you? Can you please test again with the next WIP release to make sure? this seems to be fixed, here.

-Pascal


#25

What do you know ? After 5 months of struggle, Blocks have been throttled from “Worse” to “Lame as before”. Good job !
As you might have noticed, I have long given up asking for the much needed improvements on Blocks, and I only complain if they are being screwed-up even further.