Block in plug in renderer developement kit ui

I am facing issue regarding rhino rendering is not working .I m not able to access rendering option . I have tried from option menu to bring back its not happening In that place it is showing nothing . I am facing this problem since so long plss resolve or help if one can . Also screen is showing black in rhino. I have shared the picture rendering tool is not working in my rhino and the screen colors is also changes

I suspect your computer may not meet Rhino’s System Requirements.

It might also be something easily corrected by replacing an old buggy GPU driver.

Please run the Rhino “SystemInfo” command and return the results in a reply.
This will give us a good overview of the resources Rhino sees on your computer.

Hopefully something obvious will stick out and suggest a change.

Thanks

Rhino 7 SR28 2023-2-27 (Rhino 7, 7.28.23058.03001, Git hash:master @ 4ffc5d7156fbccf2a5d9fcc80e522b3851bc7f6c)
License type: Evaluation, build 2023-02-27
License details: Stand-Alone
Expires on: 2023-05-03

Windows 11 (10.0.22621 SR0.0) or greater (Physical RAM: 7.7Gb)

Computer platform: LAPTOP - Plugged in [94% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) UHD Graphics (Intel) Memory: 1GB, Driver date: 5-26-2022 (M-D-Y).
> Integrated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA GeForce GTX 1650 (NVidia) Memory: 4GB, Driver date: 7-7-2022 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 513.39
> Integrated accelerated graphics device with 1 adapter port(s)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 7-7-2022
Driver Version: 30.0.15.1339
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.28.23058.3001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.28.23058.3001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.28.23058.3001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.28.23058.3001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.28.23058.3001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

It looks like your evaluation will expire tomorrow so unless you’re planning on purchasing a permanent Rhino license, this might all be for naught.

If it were me I would do the following:

  1. Run the combined 2015, 2017, and 2019 installer using this link from Microsoft:
    Latest supported Visual C++ Redistributable downloads | Microsoft Learn
    Use the 64-bit tool since Rhino is a 64-bit application.
  2. Run the .NET repair tool from Microsoft:
    https://www.microsoft.com/en-us/download/details.aspx?id=30135
  3. Repair Rhino 7:
    a. Windows Control Panel
    b. Add/Remove programs
    c. Select Rhino
    d. Click Change
    e. Click Repair

Don’t be surprised if you need to restart Windows.

Any luck?

i have tried to repair but its doesnt happened anything also i just bought this laptop ! pls help what should i need to do

New laptop?
My guess is you haven’t run Windows’ Check for Updates yet.

Please run CFU, install, reboot, and run again.
Repeat until Windows 11 is up to date.

“New” computers are never delivered fully up to date.
They are not ready for Software until they are fully updated.

Thanks

now i m updating my windows to 11 lets see what happen will revert it then

i have installed the update but not happen anything

???help please

Also be sure to grab updated drivers for both your Intel and Nvidia graphics cards :slight_smile:
HTH, Jakob