Black texture, not the first, or even tenth time having this issue

on the simplest things… textures in render mode go black. Why isnt this fixed yet?

Provide more info and you might get an answer!

Edit: Windows or Mac; Choose a category.

Hi @stephen7,

Can you launch Rhino 6, run the SystemInfo command, and paste the results here?


– Dale

CMYK image file?

1 Like


This is not the only thread in the forum that speaks to this issue. Its a transparent texture using a png type image, RGB color, 8 bit/channel. Created and exported directly out of Photoshop.

I have mapped it using a cylindrical mapping onto a curve that i revolved into a bottle. Then after the NURBS was mapped, i split the top and bottom off using the isocurve method to make a label. When i applied the texture, it works sometimes, then gives the black texture about 50% of the time. The most crucial of times.

Honestly this makes rhino unusable, With inconsistent display modes I cannot properly produce my schedule. Let alone count the hours dealing with the scenario when it happens. I love rhino, ive used it for almost 10 years now. But this has been happening since rhino 6 came out. Last night this happened in front of a client. A simple demo that takes 2 mins and I was left with explaining to him that rhino is a good program instead of the concept of the piece.

I would love to hear McNeels thoughts on this issue. The forum is full of posts about black textures. Ive also completely given up editing any texture inside rhino natively, as that also produces the same results. Adding transparency, the list goes on.

This machine info at the time of the incidenet:
Rhino 6 SR20 2019-10-22 (Rhino 6, 6.20.19295.13421, Git hash:master @ 481f93f930741c2cc1997daf4bf3bc69627e071e)
License type: Evaluation, build 2019-10-22
License details: Cloud Zoo. In use by: Stephen Bontly ()
Expires on: 2019-11-16

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name: MSI

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce GTX 980M (NVidia) Memory: 8GB, Driver date: 1-30-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 418.81

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 1-30-2019
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 8 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.20.19295.13421
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.20.19295.13421
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.20.19295.13421
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.20.19295.13421
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

I see that my GPU driver is outdated. im updating now, but i highly doubt that it will make the difference. It hasnt been fixed in any other releases.

Im currently updating.

I did notice that RefreshAllTextures or a restart of Rhino can solve this issue for a sometimes short period of time until I would get not just some black textures, but even a whole black screen again. This is on a Mac, so graphic card drivers should not be an issue here.

No response to this situation? I received immediate feedback on my first post but its been pretty silent from McNeel since my second. Do you have any updates?

This is a huge inconsistency in the architecture. And im not the only one with this issue. What is causing this to happen?

@stephen7, if possible, zip the png file and post it or send it to McNeel for instapection.

Rhino caches textures and it could be that it still loads a cached one instead of the one you may have edited and saved using the same name. I see this problem a lot and often have either to reassign using a different name after edits or clear the texture cache to make it behave.


Hey @clement,

This post is really about the issue I have with the Rhino support team. I know the png file is fine, but its a good point about cached textures. I see you posted the command, _RefreshAllTextures, in an earlier post. Next time this black texture occurs ill try that.

But where is McNeel?!? Every time there is a post about this they go silent? Why is this? Where is the team that is supposed to give us an answer? All i can come up with is that it is a major flaw in their system and they dont know what is going on.

At this point im just looking for a confirmation that it is impossible to fix so i can at least sleep better at night. Or that it is my GPU so i can replace. Its happened on multiple computers, so i doubt its the latter.

Honestly, i need something official so i can move forward with anything dealing with rhino renderings. Are custom textures with texture mapping just not Rhinos thing? Maybe it will be better in r7? Its ok, i have other pipelines, but you need to come out and tell us some solid facts about how to proceed.

Looking forward.

Hi Stephen,

Could you send us the model which often causes issues for you? I’ll do my best to try to reproduce this issue but it will be hard if I don’t have the model.



Hey David,

Thank you for reaching out. The _RefreshAllTextures command might be the golden ticket.

ive tested 8 bit png, 16 bit png and an 8 bit jpeg. All go black when i start adjusting values in the material editor. but when i run the command it brings them back.

Is this something that we should be doing habitually?

TBH ive noticed a dramatic decrease in the black texture incident over the past year. It just happens to always hit at the wrong moment in time.

This is only a test file, so im not sure what it will be like on a bigger project. When i can find time to send something through i will.

For those who like buttons.


It’s good that RefreshAllTextures works, but ideally you shouldn’t have to use that.

I just tried to reproduce this issue by creating something that looks like your screen shot, but I don’t see any issues. Could you send me the file from your screen shot? There might be something I’m doing differently.


Ok Ive had to recreate because i closed out. But the problem persists. I noitce when i save it must refresh the textures. but ive placed the textures im using in the file with an image explaining the scenario right as i last saved. Youll notice in the material properties, under color adjustments ive got alot of custom settings. When i change pretty much anything on this page, outside of the texture mapping, the textures go black.

Texture testing Rhino.rar (2.1 MB)

At this moment in time im happy with the refresh textures command, so I can move forward. I will let you know if its working. Also please let me know about this file. Im curious.

Thank you!

Hi @stephen7,

Thanks for the model.

I wasn’t able to reproduce the black object issue with the same build as you have (Rhino 6, 6.20.19295.13421), however I was able to see black objects in a slightly earlier build. As far as I know, the black object problem should be fixed in the latest version.

I’m wondering if you could try reproducing the problem in the very latest Service Release Candidate you can get (Rhino 6, 6.20.19302.15121), after you’ve deleted Rhino’s temp files from here: