Assembly reference warning again

Hi all,

I had the same question a while ago, which never got resolved. I am building a plugin using Rhino7 Mac and Visual Studio Mac, and when I reference a DLL, I got this warning.

I understand this has something to do with RhinoCommon version compatibility, but I have updated both Rhino and the Rhino NuGet package in visual studio. Strangely enough, I still see their versions differ as in the attached screen capture. Sometimes the warning goes away when hitting the “Run Script” button in the editor multiple times.

You probably need to use assembly redirect in an app.config file, see

@menno thanks for the reply. Where do I need to do this? In the dll’s config?

I still think this is a bug because this warning goes away if I hit the “run” button couple of times…

You need to add an ‘app.config’ file to the DLL’s project - right-click it in visual studio, select “Add new item”, then search for the application config:

@menno Thanks for the reply. I added the app.config as you suggested, but I still see the same warning. Any thoughts?

I think the oldVersion and newVersion may need to be swapped.

I tried, but it still doesn’t work. I also tried bypassing publisher policy, but it doesn’t work either.

I’m sorry, but then I don’t know what is going on or how to fix it.

No worries! Thank you anyway. I think this is something that McNeel should respond.

Could someone at McNeel please take a look at this?