Anti aliased pen viewport?


when i export the pen viewport it’s not anti aliased
what should i do?
is there any way?


(Brian James) #2

Technical modes like pen use AA here when saving the viewport as an image with ViewCaptureToFile. Are you exporting the image in another way? Also check that you have AA enabled in Options>View>OpenGL.

Provide a screenshot of the OpenGL settings, the 3dm and a sample of your saved image if you still need help please. Thanks.


yes AA is enabled with 8x

(Brian James) #4

Can you post a screenshot of the OpenGL settings, the 3dm and a sample of your saved image?


(Brian James) #6

Thanks, it looks like AA is working in the viewport. How are you Exporting the image? ViewCaptureToFile or Print?

I think you might need to update your graphics card driver too… see the link below if you need help with how to do that.


i export to jpeg

(Brian James) #8

How? What command do you use? Let me know more if updating the driver doesn’t help.



then i change the resolution to 1080p

but the the line of pen viewport are not so aliased

(Brian James) #10

Can you post the jpg and your 3dm? Did updating the GPU driver help?


sorry i can’t , i’m in contact with htc for my designs
let me send you another image


this export is not good enough to fulfill my expectation

(Brian James) #13

It looks like it’s using AA to me, you could compare a viewcapture to one with the AA level in the OpenGL settings set to None as a test to see.

If you already upgraded your GPU driver my only other suggestion would be to use the dashed version of the command “-ViewcaptureToFile” and then capture the image at a larger resolution (e.g. 5000x3500) than you need. Scale that image down to 1920x1080 and see if it works better for you.


thank you, by the way what a great community and really great support and i will recommend anyone to use rhino

(Brian James) #15


(Miguel Villegas Ballesta) #16

To me it seems indeed antialised. Have you thought of increasing image capture dimensions and then downsizing it in an image editor? Autocad didn´t antialiase its exports and that is the method I used.
High res image> 0,2 pixel blur>decrease image size or increase contrast a little.