Animation recording

Trying to do animation [for the first time]
target folder … first you see a Windows D [drive I guess]. then it actually is looking for somewhere in Rhino 4

I tried to put it on desktop , got that strange error massage.
it runs the animation, but doesn’t save it any where [no D drive and no Rhino 4 here]

Thanks a lot

Hey @Akash, thank you for the report. I’ve logged a bug report in our system:

@Akash Thanks for reporting this. I noticed the error last week too and it was fixed in RH-53223 Animation: MACFAIL hit while trying to do simple Turntable. You should see that fix in the next RhinoBETA.

As for the D: drive letter issue, that I cannot reproduce. (I have no idea how @nathanletwory can.) I would be curious to hear how you are able to.

If you click on the box D: it is possible to delete the content, then insert for example “documents” at which point a window will open where the path is indicated. I believe there is something strange here.


I’m afraid I still can’t reproduce the D: drive issue. I wish I could. I can’t see anywhere obvious in code that would be the culprit.

The error that comes afterward though, that should be fixed in the latest RhinoBETA.

thank you Dan
I’m now able to use the turntable animation.
a few points that I can see:
1) the rhino 4. D drive default path is still there.
2) the path window is very small uncomfortable to use, and looks outdated [rhino 4 look]. would be nice to have it open as a dropdown where we can see the whole path.
3) I can not find a setting to control the frame speed! the transition between frames is currently too fast for my purpose of showing an item of jewellery, I need it to revolve slowly and gently.
3a). so I can raise the number of frames and it goes slower, but this results in a very large number of images and is too large to use in a website.
3b) a speed control slider, + a fade in fade out smooth transition affect option, will make it a better tool, AFAICS.
thanks a lot

I was finally able to reproduce this one, but it required resetting all my preferences to the factory defaults. Once you have set a new path for this, it should stick though. I logged this in:

RH-53429 RecordAnimation: Initial folder is Windows-specific.