Aligning ortho axis with rectangular geometry

Hello. I’m new to Rhino and have a basic issue that seems to have no answer when I google it.

I’m setting up basic rectangular geometry, modern architecture with simple planes. While working with the Top view, the geometry is rotated approximately 45 degrees so that the top of the screen is ‘North’ in my mind. See image.

I’ve managed to align the CPlane to the geometry using the 3 point method. The trouble is that I need ortho (lines drawing 90° to one another in an x,y,z directions) to be aligned with the rectangles. The lines or curves continue to follow some random directions and I can’t seem to draw a vertical line at all. See the image below for what I mean when I describe the random direction the lines are following. The random directions are not ortho to each other (90°).

See the image below for what I’m working with. Thank you for your help. I certainly appreciate it.


Hi Breck, did you try line command with vertical?

Also you can select one of your rectangular objects, make sure the gumball is in default alignment, run CPlane command and set it to gumball


Regarding the line command, if I’m trying to draw a polyline that I will turn into a plane, the linwork stays flat and I cannot go vertical.

Regarding the rectangular objects, I’m not familiar with gumball but I’ll look into it now. Are you saying I can tell the CPlane to lock orthogonally to the direction of the rectangular objects.

The goal is something similar to Sketchup. I’d like an x,y,z axis that I can draw on and be confident that the linework and shapes are rectangular to this x,y,z axis. Is this possible in Rhino? I’m asking now that I’ve bought the program.

I’m glad you bought Rhino and not sketchup :slight_smile:

1 Like

did you check the ‘project’ option? make sure it’s off? run ProjectOsnap and choose ‘disable’ - also when you run CPlane command you can align that to an individual face of your rectangular solids - alternatively you may choose InterpCrvOnSrf command to draw curves (not a polyline) directly on an individual face or on a surface

Hi Corellaman.

Would you be interested in sorting out this issue with me on a Zoom screensharing conference? I’d be happy to pay you for your time, via Venmo or Paypal. I’m an architect on a deadline and need to sort this problem out asap!

Let me know what you think. Thanks.

Hi Breck.

You have discovered the most important feature, the CPlane. What I did not see anybody mentioning sofar are the Ortho lock and the Object snap.
Lines can be started from an existing point on the geometry, or seemingly “in space”. When you start a line in space, Rhino cannot distinguish where exactly you wish to put the starting point, it can be any point on that line-of-sight. So, it will default to a point ON the Cplane. Unless you start or end by snapping to a point on existing geometry, the line will always be on the CPlane. Vertical lines can only be created by selecting the Vertical option of certain commands, or by snapping on appropriate points that you know will result in a vertical line
When the Ortho lock is on, lines will always be parallel to the X or Y axis, again unless you snap to an existing point. Again no vertical lines unless you use existing points.
When a line is started from an existing point that is not on the CPlane, with Ortho lock on, the resulting line will nevertheless remain parallel to an axis, i.e. remain at the same z-elevation, even when you end it in space.

Ortho lock button:


Object snaps:


Hope this helps you along.

1 Like

Hi Brekck, thank you - though I do teach Rhino/Gh for work I’d drive you nuts with my windows interface.

I’d go with @maxz 's assistance. Plus I don’t know where buttons are - only commands.

Best of luck

One more thing to add, it may be obvious to you, but then again you may not have realised this yet: when you move (or copy) stuff around, it is not necessary to locate the starting point of the move at a point on the geometry you want to move. You can pick a point on the CPlane where you are not bothered by unwanted snapping on other geometry, ortho lock on, and move it parallel to the X or Y-axis (or even with the ortho lock off in a non-orto direction, but maintaining the same elevation). By typing a number you can easily control the distance of the move, but you have to finish the operation by clicking on a point in the required direction.


Another useful trick: the Project Osnap. It is not an object snap as such, unlike the others it does not define a point on features of geometry, but rather projects any point you pick onto the CPlane, not just snapped points.
You can use this particularly well on parallel viewports (front, right, top, etc.)where you want to move stuff in the middle of busy geometry, without the risk of shifting it in the “invisible” direction, i.e. perpendicular to the screen. When you select stuff to move and then click to pick the start- and endpoints, both will be the projection of those points onto the CPlane, and the object will move along a path parallel to the screen only. Clearly, the CPlane will have to be parallel to the viewport as well, i.e. in the default orientation or moved in the z-direction only.

Note that the Project Osnap will remain active even when you do “Disable all”, or do “One shot”


Thank you Maxz and Corellaman for trying to help me out.

I’m not sure I’ve explained the issue well enough so I’ve uploaded a video of the screen below. Notice how the CPlane is aligned with the rectangular objects and ortho is on but the lines/curves do not follow the geometry. They are held to some other, random, directions?

What are they following and how to I get the x and y directions to always follwo the rectangular geometry?

Thank you both again.

Hi Breck,

I have watched your video, and tried a few options to reproduce what I saw, but sorry, I cannot replicate that behaviour. Except when I press and hold down the shift key, which effectively disables the ortho snapping temporarily. A stuck shift key springs to mind, but I guess you would have noticed that earlier.


P.S. the line indicating the position of the line resulting from the chosen end point is dotted, something I don’t see on my version. A clou for the real experts…?


Probably better if you share a model or a fragment of it? Also, have you left ‘smart track’ turned on to see if the axes are indicated/projected for you to draft your lines?

After your first point of a polyline, try pressing shift + alt (or its equivalent on mac) together to test if you can enable/disable smart track.

I tried smart track on my mac, still not seeing the same as Breck…

Thank you both for sticking with me on this.

Even when I start a new file and just begin to draw a rectangle polyline/curve the direction is still held to this random increment of angle but not along the x , y grid of the CPlane.

Is there anyone on this forum that understands this issue? How about the people who work for Rhino? Any ideas on how to speak with them? I must have some setting turned on because it’s impossible to work like this so what is happening cannot logically be a part of the program workflow.

Thank you for the help.

Your video is too small and fuzzy for me to see what’s really going on, but what happens if you type OrthoAngle and set it to 90°? From what I can barely make out on the screen, seems like it got set to some other value.

@Helvetosaur that must be a general bug from the discourse, when you download that video its very large actually. fullscreening the videos still displays them small, so there is some bug for sure. i thought i was the only one having issues with this because i use a mac.

for the rest i agree, it looks like he has the Ortho Snaps screwed down to something like 15° . strange is that it does not start at its own tangent but gaps it out.

@breck can you go to rhino preferences cmd, to modeling aids and make a screenshot from snaps and smarttrack?

edit: you can also try ResetPreferences if you have not set up anything significant to be sure it resets to its normal values. maybe also upload a part of your file.

Probably, I can’t even see the video directly in Discourse on a Windows computer here (it’s just white), I had to fire up my Mac to be able to see it on Discourse. Yes, you’re right, it is OK if I download it.

on my iphone it displays white either, would not load or initiate, only on the mac. maybe this happens when somebody uses the .mov video format, or because its too big (pixels) or even too big by the file size, it is after all a 17 mb video for a few seconds… i cant actually remember if this happens all the time but can remember having this issue frequently.