Add Boolean commands to subd rhino7?

HI
Adding Boolean commands to the subd will be very effective

4 Likes

and add thickness in subd
because now (when i use offsetsolid to subd)
the subd change to polysurface and don’t work!!

4 Likes

Hi
@BrianJ
:crossed_fingers::crossed_fingers::crossed_fingers:

OffsetSrf SubD support is filed as RH-53773 for future reference, I added your vote.

@mehran09197306634me Boolean support for SubD without conversion to Breps is filed as RH-51867 and I added your vote. The best I could suggest now is using QuadRemesh after the Boolean to make a new SubD.

3 Likes

+1
I would like to add my vote as well for both OffsetSrf Sub-D and Boolean support for Sub-D. Great suggestions!

From: https://discourse.mcneel.com/faq
“Rather than posting “+1” or “Agreed”, use the Like button.”
snap00%2010-18-2019

1 Like

Question out of curiosity? How would Boolean operations for SubD be expected to work? Would the underlying mesh be refined until results matched the intersection curves of the input SubD surfaces within a tolerance?

2 Likes

Yeah, it doesn’t make sense. I can’t think of many applications where this would both be useful and also not result in a mess.
This command in Clayoo, which creates subdivision lines at a planar intersection, might be a useful tool in pursuing merging two subD objects. But directly unioning and differenceing don’t.

The only way I see it making sense is a Boolean with history. Where each of the Boolean inputs preserve their own topology and the result is either a trimmed SubD (is that even possible?) or a polysurface/brep made out of converted SubDs, but the inputs stay ‘live’, so what we need might be Teo things:

  • a trimmed SubD topology type
  • a grasshopper module for Boolean SubD.

G

RH-53773 is fixed in the latest WIP

Just tested this. It seems like it only allows _OffsetSrf to be used on a SubD and produce a NURBs polysurface as output, taking one step out of the process of converting to NURBs and then offsetting.

Feature request: SubD output.

1 Like

OffsetSrf has not changed. Call OffsetSubD. It was not combined with OffsetSrf for various reasons. It is more like OffsetMesh.

Nice!

Makes perfect sense that it would be called offsetsubD.