About problems installing Kangaroo2 Components 2.5.3

Hello! When I opened Grasshopper, a prompt window popped up, indicating that I was missing Plug-in, and when I clicked “Download and Install”, the pop-up Package Restore window said "404: No package found by name of ‘Kangaroo2 Components’.

Failed to install the missing plug-in.

Not all plug-ins were found on the package server.

The missing plug-in(s) may be available at https://www.food4rhino.com.”

May I ask how I need to solve this problem?

In addition, I’m in my hard drive directory “C:/Program Files/Rhino 6\Plug-ins/Grasshopper/Components” and “C:/Program Files/Rhino 7\Plug-ins/Grasshopper/Components”
The “Kangaroo2Component.gha” component was found in it, so why would you be prompted to miss it?

Hi - When you are running Rhino 7, you shouldn’t have to install Kangaroo. Can you upload the gh file that is causing that pop-up?
-wim


That’s the pop-up prompt that pops up whenever I open Grasshopper. How can I solve this problem?

Hi -

Please run the Rhino SystemInfo command and copy-paste the result here.
-wim

Rhino 7 SR1 2020-11-9 (Rhino 7, 7.1.20314.23101, Git hash:master @ fa195ba04c9d96d11c7c83b524ea82cdf6a4da15)
License type: Commercia, 2020-11-09
License details: Stand-Alone

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce GTX 1050 Ti (NVidia) Memory: 4GB, Driver date: 1-22-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 461.40

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 1-22-2021
Driver Version: 27.21.14.6140
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Hi -

You’ll need to update your Rhino version. The current version is Rhino 7.11. Go to the Options > Updates and Statistics page and make sure to check the Enable Updates and Usage Statistics checkbox.
-wim