About Eddy

hi @seghierkhaled. Can you please share your script to check. To answer your next question eddy doesnt have such feature as it becomes quite complicated to generate heavy mesh inside rhino. Paraview is intensively for that.

The script is included in eddy plugin
Wind anslysis with tree


When i clean the file ; calculation (RunSim) don’t work again
i solve this by using python code to clean folder than recompute (F5) than RunSim

import os
mypath = x
for root, dirs, files in os.walk(mypath):
for file in files:
    if y == True:
        os.remove(os.path.join(root, file))

1 Like

Did you create a 3D grid to have those results?

Hi @ seghierkhaled

Could you tell me how did you get the visualization in the second image?

I know that Paraview can generate the same result, but I’m curious if and how it can be done inside grasshopper.

Thank you

Personnaly I’m using the py script developped in the discussion below simpledrainage_te.gh (92.6 KB)

1 Like

Thanks!
I’ll look into it and try to implement it with my workflow.

Have you tried it with Eddy3D?
Since I’m not very familiar with field lines, would I need a 3D grid of points that covers my area of interest in the wind tunnel with appropriate velocity vectors or just starting points at the beginning of the wind tunnel with their vectors?

Yes 3d grid points give better result

I export vrml file from paraview and import it

I see, thanks again.

THe definition isn’t not perfect but maybe it can inspire you :wink:

caseA.gh (50.2 KB)

1 Like

Nice script, of course paraview better but this give nice result

1 Like

Hi @timkado . I am trying to use annual outdoor comfort. Everything runs well but Rhino crashes when I toggle MRT component. I also installed Radiance 5.3 in c drive program files. Is there a way to solve this repetitive error.

Anyone can provide some assistance here?

Hi! I have a basic knowledge of Grasshopper and I’ve just started with Eddy. I’m trying to run the “SimpleWindAnalysis” example following the official web site tutorial but I have problems when I run “Visualize Probes”. It should create the wind vectors but there is a mistake and the vectors appear in all directions and oversized. There is also a message with the next information: “can’t be probed within the simulation domain and have been discarded”.

Imagen1

Hi,

It is hard to tell exactly what your issue could be. A few things pop into mind:

  • It seems you are trying to probe inside a mass that is in your simulation? If this is the case, it could explain your issues. You cannot probe right now inside of a mass.

  • How many Iterations did you run? If you ran only a small number of iterations (say 100) than this could also explain the extreme and unrealistic vectors since it likely could not converge the solution enough. If you ran a large number of iterations and it is like this, then check the Residuals plot and see if that specific wind direction completed all the iterations - or if it stopped short. This would indicate it “broke”, for some reason and was not able to complete. Generally I would run no less than 500 iterations for a reasonable simulation outcome.

Honestly though it could be many other things as well. Hope this helps.

Has anyone run this annual wind analysis thing on a site that is 1x1km large? Been running the simulation since yesterday 10pm, its been 12h…

Hi, how big is your site? Am struggling with my 1x1km site…

Hi, @aeaechan96

You should be able to run sites that are much bigger than 1km x 1km. How detailed is your model? What meshing settings did you use? How many iterations? It would be helpful to see a screenshot of your model and grasshopper script setup as it could be many things.

That said, depending on the power of your computer and # of CPUs you can use, it could take a long time to do a big simulation. For reference, I did, on my laptop, a 1km x 1km simulation a couple weeks ago w/ 4CPUs & 16GB RAM for 1,000 iterations and a basic mesh and it took almost 12 hours for 16 wind directions.

Thanks,
Remy (Eddy Team)

Hi Remy,

Would you mind sharing the mesh settings you used for such a large model please? The roughness (z0) would also be very helpful for reference.

I’ve struggled to yield sensible results for a masterplan geometry (1.3km radius and height), with the ground’s boundary layer seemingly being too large (zero velocity at pedestrian level; the ABL looks sensible upwards of that height though). I’ve had the same issue for even very basic small box geometries (e.g. 4m cube); I’ve found it to respond to a desired cell size of 0.25m (3 layers), but this seems impractical for a masterplan. (Meshing my masterplan with even DC = 0.5m gave a mesh of well over 16GB)

Any help is greatly appreciated.

Kind regards,
Julia