A problem of Rhino WIP


I have had a question with regards to Rhino WIP.
I heard that “Multiplication (AxB)” could handle the problem of large numbers by Rhino WIP, previously.
However, “Duplicate Data (Dup)” has had another problem afterwards, as the attached image shows.
I was just wondering if there is any solution to that problem.

Thank you

Try bypassing the text panel? That is an absurdly large number!? But I wouldn’t be surprised if the text representation causes numeric inputs to fail.

P.S. Maybe not…

Thank you for replying.

Did you mean that I should remove the panel existing between the red “Dup” and “AxB”?
I have tried it, but the way has not solved the problem.

The red warning has shown “1. Data conversion failed from Number to Integer”.

Thank you

Bypass it, not remove it. Generally a good idea, especially with geometry instead of numbers.

Here’s the error I see using an arbitrary big number: 329875432

  1. Solution exception:Array dimensions exceeded supported range.

Thank you both.
I’ve filed this as RH-60068.

Thank you for doing that.

Yeah that’s a problem all right. Data in grasshopper is stored inside reference types, meaning a 64 bit pointer per item. Add to that the data itself, in this case a 64 bit floating point number. That’s 128 bits or 8 bytes per item. 8 × 329875432 = roughly 2500 megabytes of memory being used to store the value 0.5 over and over again.