A little difficulty with MeshMachine

Good day. Tried to install a mesh machine on my pc so i can continue working on a file started by another person. But after adding a GHA file in Library nothing happened in the Grasshopper. I still cannot fully open the file in wich the mesh machine was used. Also cant find it in the search.
At the same time during the opening of the program there happens a file conflict error.
I tried Rhino 6 and 7.
Attached screenshots and working file

I would be thankful if someone suggests a solution!
File conflict|690x450 MeshMachine and Planton

7 Rhomboid solders.gh (66.1 KB)

Have you unblocked the two files?

Hi @Kyshtym_gnome
One option could be to replace the MeshMachine component with the new TriRemesh(which is essentially an improved MeshMachine, and as it is built in doesn’t need you to set any library references) like this:
7 Rhomboid solders.gh (45.2 KB)

Yes, they are both unblocked. Also get this error message when open

the file

Good day. And what is better in that way, SimpleRemesh or TriRemesh?
(As you ve already seen, i need to make an inflatable airtight structure with seams in the middle. May be i should create a separate topic about an easier and more elegant way to solve the problem?)

And anyway i would like to understand the reason why my pc doesnt see MeshMachine.
After installing it the same way on a working computer everything worked fine…

TriRemesh is the current one, and what I recommend using. It was a complete rewrite with lots of improvements over all the old MeshMachine and SimpleRemesh components (which would sometimes fail without reason).

The approach as in the file above of moving the boundary vertices and joining the mesh to a mirror of itself is a good one for making an inflatable airtight structure with a seam in the middle.

I suspect the reason why the MeshMachine component wasn’t loading was that some releases of it referenced a file called PlanktonGh.dll, which was actually just a renamed copy of Plankton.gha. This was used because of an old issue with referencing .gha files in Visual Studio.
image
PlanktonLibraries.zip (42.9 KB)

Like I say though - TriRemesher avoids these library issues, gives better triangulations and is more reliable.

1 Like

Ok i will try. Thank you for the explanation