1. Solution exception: index was out of rage. Multipipe

Hi I’m getting this error message when trying to do the multipipe. How could I possibly start solving this?

Can you post the file of the input curves you are passing it?

1 Like

Hi Daniel! Here are the files I’m currently working with.

geometry and lines for multipipe.3dm (2.9 MB)
Uploading: voronoi and multipipe.gh…

I first thought that the error was because of duplicate lines, but because I for some reason wasn’t able to remove the duplicate lines on grasshopper, I baked the lines and removed the duplicates on rhino, but the multipipe was still not working. I’m assuming it has something to do with the planar lines in the list, since the multipipe worked just fine in the previous version and the only difference I spotted was that in the previous version had only line like curves. But I would still prefer to use this new set of lines, but I don’t really know what I need to do to make the multipipe work with them… It would be amazing if you would know how to solve this! :slight_smile:

voronoi and multipipe.gh (235.5 KB)

voronoi and multipipe.gh (229.0 KB)

Your file had thousands of extremely short and overlapping segments. Collapsing some of these as shown is a quick fix that lets multipipe run, but to get a really nice result you’d need to clean up the lines a lot more, or generate it in a different way.

1 Like

Oh thank you so much Daniel! This really helps me to move forward with the project. And thank you for such a quick reply! :slight_smile: