What is the difference between Hops and clusters?

@mohammedbehjooarchic Please also share screenshots of any error messages and/or details of what is preventing you from installing hops with the Package Manager.

You should buy a legal license, and install an official build. We don’t support cracked versions.


For anyone else reading, the error was “The request was aborted. Could not create SSL/TLS secure channel.”.

This should be fixed in the current 7.11 release candidate.

any new developments here?

No development has been done here yet. This is a Rhino 8 project.

Got it, thanks!

I know this is a classical question, but is there a rough ETA? Will this be a 8.0 feature or 8.x?


I don’t have an eta. This is not actively being worked on at the moment.

Does that mean, that the hops computations will not be a separate process and thus not utilising the multi-core benefits, or am I wrong?

You are correct. We do not have “Rhino.Inside” working on Mac so we would not be able to use multiple processes to solve

Got it! But hops running inside one process does not mean that multiple cores of the CPU couldn’t still be utilised no? Here is a CPU usage screenshot when I open a larger Kangaroo definition with RH8 (I guess running inside one Rhino process?)

Furthermore, would the ability to run hops components as separate processes go hand in hand with the ability to run multiple Rhino sessions as separate processes?

If yes, it would of course be an awesome thing to develop both these features in one go… in theory.

What’s the talk of the town around dynamo grasshopper compatibility ? I know they are on two different ecosystems but we have Rhino.inside.revit soooo, who knows

Hello all, shameless repost from developper.rhino, I just tried this component on windows 10 64 Rhino 7 with an AMD processor
The components appear and I set up some code just like in the demos but the hops component doesn’t show the inputs and outputs

All latest realease as of this date

Hi Thomas -

Yes, we have that issue on the list as COMPUTE-241. I’ve added this thread.

1 Like

Cool, so it’s related to those functions starting automatically and the process getting lost in there. Nothing to do with my processor, gut

I’m not sure what the cause is yet. For now I would recommend using a previous version available on the package manager.

More specifically, you’ll have to use 0.10.1 on Rhino 7 for the time being.

1 Like

Did you do the old try and fail ?

Hi @thomas.lagarde. We have figured out what’s causing some computers to not launch the rhino.compute instance when you launch Grasshopper and we will be issuing a patch very soon. However, in the meantime, you can bypass this issue by following this thread. Let us know if you run into any other troubles.