V6 Video Card Compatibility?

Hi there, evaluating upgrade from V5 to V6, and I’m having issues with V6, especially with Make2D drawing. It appears that many lines on screen aren’t visible, but when printed to PDF they are in fact there. See attached images showing difference in screen output between V5 and V6. Additionally, V6 when in wireframe mode doesn’t draw all edges, and has a tendency to “flicker” when the model is rotated. I’m assuming these issues are related to the specific graphic card I’m using? It’s an AMD Firepro V7900, not exactly a slouch, but now showing it’s age… Have these issues been noticed before on the AMD cards? If the issues are related to the graphics card, what would be a good graphics card that wouldn’

V6 Print to PDF.pdf (209.5 KB)
t break the bank?

Hi - Could you please run the Rhino SystemInfo command and post the result here? Thanks!

Hi Wim, I had additional issues after installing Vray for Rhino demo that caused my system to hang, I ended up uninstalling V6 (and VRAY for Rhino) as a result. No SystemInfo command in V5…

Aha… appears I only removed VRay and hadn’t uninstalled V6 after all… System info below:

Rhino 6 SR13 2019-2-27 (Rhino 6, 6.13.19058.371, Git hash:master @ 17cd8b51accbe17dd04b48028f49d5e77a67f17b)
License type: Evaluation, build 2019-02-27
License details: Stand-Alone
Expires on: 2019-06-15

Windows 10.0 SR0.0 or greater (Physical RAM: 40Gb)
Machine name: NUMBER5

Non-hybrid graphics.
Primary display and OpenGL: AMD FirePro V7900 (FireGL V) (AMD) Memory: 2GB, Driver date: 1-30-2017 (M-D-Y). OpenGL Ver: 4.5.13413 Compatibility Profile Context FireGL 15.201.2401.1010

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: ATI Technologies Inc.
Render version: 4.5
Shading Language: 4.40
Driver Date: 1-30-2017
Driver Version: 15.201.2401.1010
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Thanks for that information! The drivers were newer than I had feared.
One of our developers has the exact same card and would like to try to reproduce what you are seeing.
Would you be able to post that file that you are using in this example?

Hi Wim,

Even the zip file is too large to upload at 22MB, I can email to you if that works?

Please use this link to upload the file and include this URL in the description:

URL to add to comment
V6 Video Card Compatibility?

Hi John,

Tried a couple of times, but get a “Server Error” after attempting upload of the zip file…

Maybe you have a Google Drive or DropBox account?
Could you upload it there and send us a share link?

OK, 1st time trying Google Drive…


Thanks for that file!
I’m a bit confused about the reported issue now, though. When I open that file, there are no curves on any of the layers. From your description and images, I thought that you had problems with curves.
Do you experience any issues with the file as you posted it in that link?
Please describe in detail what the developer has to do to recreate what you are seeing.

@wim I think you need to run Make2D first.

No issues here on my laptop though, so i presume it’s a driver thing. AMD never got those right…

Hei Jørgen, Yea - but I’m wondering about things like if a specific projection is selected; is there an issue with just the curves in the file and no surfaces; if there are curves and surfaces, do they all need to be visible; etc…

There are just too many combinations and possibilities and without knowing exactly what one needs to look for, time flies very fast and Jeff has other things on his list…

Hmm, I’m wondering if your issue @acrighton is related to a similar sounding issue I’m seeing with the Mac version and v6, but not v5, on a Mac Pro with AMD cards and 4k display? (see thread below) Issue is not present on a 5k iMac with Nvidia graphics, btw.

On your system, in wireframe mode, is there a difference in sharpness between pure wires, and the wire edges of surfaces?

Also, do things get sharp in pen mode?

Yup, you’ll need to run the Make2D command :-)…

ec2638, yes, my issues appear to be very similar to what you are seeing.

If you run the Make2D command on that (4 views) and save only those curves in a new file - do you see the issue with that new file?

Hi Wim, Yes, exact same issue. I tried printing to pdf, as similarly, all is good in 2D printed output, no missing lines, and no additional surfaces showing up (black shading randomly appearing as I zoom in/out of the model).

Just checking to see if there was any additional feedback on this matter?

Not yet. I’ll get back to you!