Unknown command

Hi there. I’m using Rhino 5, on Windows. Never had a problem until tonight, but everytime I tried using Linear Array it said Uknown command. I’ve also googled to see if someone had a similar situation but it seems like it works differently for every command. Not sure how to fix this.

What if you try “ArrayLinear” instead?

// Rolf

Tried, it’s still the same. Also tried Transform toolbar-Array-Linear but didn’t work

Check PluginManager. I dunno what plug-in that command goes to but maybe you turned it off on accident? (I don’t mean third party plugins, I mean Rhino’s core)

Hm, I’m not quite sure how to check that. When I open PlugInManager this is what appears

@milabrstinic219
Here is what @Michael_Pryor is referencing:

  1. _Options or 2020-02-15_15-46-07
  2. Rhino Options >Plugins

    Make sure there is a check in Enabled
2 Likes

It seems like I don’t have Rhino Labs Tools as an option in PluginManager. Here’s what apperas in PluginManager:

Is there a way I can fix the problem differently?

Hmm you should definitely have way more plugins. Maybe something went wrong or interrupted your Rhino install. Can you reinstall it?

You are missing a lot; for comparison I have:

You could try a Repair
snap01 2-15-2020

Hm I see. Strange. Do you think that there might be some other way to fix the “unknown command” problem? Or do I need to re-install the program?

So far everything’s worked fine for me, never had any issues.

Just see what the repair process does for you. A complete uninstall/reinstall might be a good choice if repair doesn’t work. The real issue, however, would seem to be "why is some of the plugin directory missing? There’s probably many things that could have caused it that are easily avoided, but a big concern that would enter my train of thought is “is my hard drive (or SSD) going bad?”

1 Like

Okay, will try. Thank you.

1 Like