SubD missing

Hi I’m totally new to Rhino, but it might be just what I’m looking for. I tried to install RhinoComputer by following this site:

It seems almost to work, except that in the RhinoCompute.cs it doesn’t seem to know QuadRemeshParameters and I get a “type or namespace could not be found”. I think it is in Rhino.Geometry which I have referenced and use in other contexts.

Also I get a “SubD is inaccesable due to protection level”. This is also in Rhino.Geometry I think.

I’m not really sure what’s up and any help is apriciated.

Not sure what you mean by “new to Rhino”. Do you mean you are going directly to Rhino Compute with no experience at all with Rhino itself?

It would be good to know what you are trying to do so we can focus on solving the problems associated with this goal.

Yeah. That was a terrible message. I should start at the, well, start:

I’m trying to make a program in c# that can create and manipulate 3D mesh objects. What I mean is that I want to do that with c# code. But I would also like to have an interactive graphical representation, where you can click on the object, rotate, zoom etc.

So, I’ve been looking around for some library, tool or whatever that I can import in a Visual Studio environment. And I came across the Rhino NuGet package, which seemed very promissing, so I tried to follow the installation of Rhino Compute in the link, to see what I could make do (the first place I started).

So maybe I first need to know what I can do with RhinoCommon. It would seem that I need Rhinoceros, first? or is RhinoCommon free?

Rhino.Compute is designed to perform geometric calculations on a server. You aren’t going to get anything like an interactive graphical representation with compute and would need to type up all of the display and picking code yourself.

You may be interested in Rhino.Inside for what you are trying to do. This would allow you to use Rhino and all of it’s services in a desktop application that you could write with C#. An example of this can be found at

For both of the above solutions Rhino is required. RhinoCommon only works in the same process as Rhino.

We do have a lighter version of RhinoCommon called Rhino3dm which provides a subset of geometric operations and file IO that RhinoCommon provides. This is available on nuget and does not require Rhino.

This is great, I’ll look into it. Thanks a lot!

I have a few questions about Rhino.Inside. This could be really promising for us. But when I try to install the NuGet package, get this error:

Unable to find a version of ‘Grasshopper’ that is compatible with ‘Rhino.Inside 0.2.0 constraint: Grasshopper (>= 7.0.20007.12535-wip)’.

Also, it is version 0.2.0 and we would rather not hinge our future products on a limited supported package.

I plan to update the nuget package very soon.

There’s almost nothing in the Rhino.Inside dll as all it is doing is attempting to locate the installed Rhino 7 on your computer in order to load assemblies from the correct spot. You can see how little source code is in that project at.

If you are concerned about version numbers, you could just place this code directly in your own project and skip the nuget package.

This is due partly to a bug in NuGet – in my experience you’ll get this error if you’re using packages.config, but not with PackageReference. The workaround is to install the dependencies yourself before installing the Rhino.Inside package. You’ll need to check the “Include prerelease” box to install the latest beta versions of the Grasshopper, RhinoCommon and RhinoWindows packages.