SpaceMouse Pro device(approximately 13yrs old) rotates fine in R7 not R8

I have a fellow user I know of claiming to have a dilemma where their ‘rotation’ feature doesn’t work in R8 but works perfectly fine in R7.
(I extensively analyzed their machine, directly, at this point today 4_26_24)

I’m going to try and compile the solution here if/when I find out what it is.
(not much necessary to compile, see next response below, and updated title)

I know there’s been various troubles different users have been having since R8 release, but this here will be focused on whatever the cause is for this specific ‘rotation’ issue or lack thereof.

I’ll try to compile everything related to the potential cause.

(so far all I can figure is some sorta bug with older devices…)

Check if “Lock Horizon” have turned itself on. (3Dconnexion - Settings - Rhinoceros Advanced settings - Lock Horizon)

1 Like

I appreciate your thoughts. And while that’s very good advice, I tried everything. Unfortunately, nothing worked.

Except for one thing so far. And that is I plugged in a different device, and the different “newer” device works fine with no problems.

So, the only conclusion I’ve come up with so far is that the “SpaceMouse Pro” device (approximately 13yrs old) is simply not compatible with Rhino 8 – for whatever reason, maybe a bug.

And the “newer” “SpacePilot Pro” device (approximately 8 yrs old) is compatible with Rhino 8 just fine.

Therefore, it doesn’t feel right with me but that’s a good enough solution for my fellow colleague for now is he’ll just not be able to use the older one with Rhino 8…

Unless there’s some sorta update in the future that resolves this issue…

The R8 version he’s using is 8.6.24101.5001

In order to update it to something more current, I’ll need an offline download of some kind. But I’m not confident that there’s any releases that resolve this issue, considering R8.6 isn’t even working with it.

Maybe Rhino 9 will someday be more 3D mouse compatible… :crossed_fingers:t4:

While Rhino 7 works fine :sweat_smile: :sob:

Copy the 3d mouse plugin from the Plugin folder of Rhino 7 and paste it into the Plugin folder of Rhino 8 (you will need administrator account on Windows to replace the original). That should solve the planned obsolescence that “3d connexion” loves so much. :sunglasses:


This sounds like an awesome idea :sweat_smile: Unfortunately I won’t have access to the computer, againg, for a while, I’m not sure when.

I think they’ll just be using the newer device for now until then.

I sent them your suggestion, but they’re stubborn :joy:

Maybe someday and update of some kind, might fix it automatically for them :joy: :beers:

I really appreciate learning that trick though, I’ll look forward to trying it sometime :beers: :slightly_smiling_face:

I’m trying to get him to do it :joy: grr he so stubborn :rofl:

I’m honestly surprised he tryna finally learn version 8 without really getting familar with 7.

Sub’d s and quadremesh and shrinkwrap blowing his mind rn :rofl:

cheers :beers:

1 Like

The support for my SpacePilot suddenly ended with Rhino 6.4 (earlier Rhino 6 versions came with a 3d mouse plug-in from Rhino 5), so I’m using an older plug-in with my Rhino 7 and everything works flawlessly. :sunglasses: The only downside is that I have to repeat the process of replacing the plug-in every time I update Rhino 7, but that takes just a minute.

I use this plug-in together with 3DxWare64_v10-3-0_r2161:
3dxrhino.rhp (444.2 KB)

1 Like

That’s interesting, I didn’t know that would work in 7 :sweat_smile:

I didn’t use V6 very much, I kinda skipped it. I remember R5 having that situation where you could choose which driver to use. It sounds like you found a way to use it it v7 and v8?! :open_mouth:

wait what :face_with_monocle: :dizzy_face: :exploding_head: in v8 too? :sweat_smile:

That’s interesting! now tell me it works with v8 :sweat_smile: :joy:

1 Like

Yes, I can confirm that this “hack” works perfectly fine in Rhino 8 BETA, as well (I don’t have the commercial version). :smiley:

1 Like