Select Guide Curves

For large meshes, when using QuadRemesh, selecting guide curves generally requires manual selection, which given the object size, can be quite tedious; I can box-select, but that also selects srf/msh edges as well.
For a work-around:

  1. Place srf/msh & crvs on separate layers
  2. Deselect all
  3. QuadRemesh
  4. Sel srf/msh
    a. Turn off srf/msh layer
    b. Click To Continue
  5. Now select guide curves via box, since srf/msh is now off

It would be great to be able to access the Layer panel while QuadRemesh is in selection mode.

I would not recommend turning off the layer that contains the object you’re working with. Because of that, you can click the Hide Input objects checkbox on the Quad Remesh dialog to ensure you don’t select any edges if your original object. If you feel the object is too large for the preview then selecting the layers with curves or grouping your curves is probably a good alternative.

EDIT:
Negative: select guide curves does not recognize groups (7WIP).

formerly:_____________
Thx for the tip.
Grouping: good idea!

Thanks I’ll make sure you can pick curve groups. For now there’s hiding the input or right click the layer with the curves and select objects.

https://mcneel.myjetbrains.com/youtrack/issue/RH-57173

Thx, Travis - I’ll have to look again–I didn’t see the option to hide the input objects, maybe it’s sneaky; Likewise, the “right click the layer with curves and select objects” is exactly the issue I am trying to illuminate: the Layer Panel is not accessible/responsive once the rhQuadRemesh dialog box opens–only pick or box selection seems possible.
WIP: 7.0.20049.13225, 02/18/2020

I assume you’re using the windows build?

I am able to select curves by right clicking the layer during the prompt to pick guide curves.

The Hide Input Objects is available if previews are enabled. (See screen shots)

Ah, yes–the hide input objects is sneaky: due to the anticipated size I hadn’t enabled preview;
Looks like the right-click was extremely sluggish to the point of unresponsiveness on my end due to the size (it’s not enormous–just possibly imperfect geometry gumming up the works methinks). Thank you for verifying!

-dt

1 Like

@dtmurcielago I also just made some changes that will allow you run the command with either objects or curves preselected and the preselected curves will be used as guide curves.

-nice. I’ll give it a try next time around!