Rhinogold 4.0 trial version "unable to load plug in"

I just downloaded the rhinogold 4.0 trial version with rhino from the website and when I try to open rhinogold I get an error “unable to load plugin”. I click on details and it says that the plugin was designed to run on the latest rhino 5 service release. I try to download the service release but it asks for a license code and I don’t have one as it is a trial version. PLEASE help me to fix this. I just bought an expensive computer specifically for this purpose.


I think you can just re-download the full version (not the service release) and install that over what you already have. The latest full version should also be the latest service release.


Ok. Thanks for your response. You mean install the full version of rhino? I dont have a license for that either. I downloaded both together when I got the trial version from the website. I will try it when I get home though. At work now.

The full version will either install as a licensed version if you enter a license key while installing, or as an eval version if not. So in theory, installing it should bring your eval version up to date, assuming you still have some time left in the 90 day evaluation period.

What’s odd is that if you downloaded both Rhino and RhinoGold together (from which website?) they both should be the most recent versions…


Yes. I thought so too. I got the download from the rhinogold website. Clicked on the “try” link and selected the option to download both rhino 5 and rhinogold. I have uninstalled and tried the process over again but still not working. Rhino opens but it won’t open the rhinogold plugin. I may just have to call support tomorrow during business hours.

From the rhinogold website. Clicked on the try link and downloaded both together. I agree it should be the most recent version. Not sure why its not working. I may just have to call support during business hours tomorrow.

Sent via the Samsung Galaxy S™ III, an AT&T 4G LTE smartphone

@rafaeldelmolino, any idea about this?



My brother suggested i uninstall both rhino and rhino gold and then download them again separately instead of using the “package” link. It worked! Thanks for taking an interest in my problem. Much appreciated.

Sent via the Samsung Galaxy S™ III, an AT&T 4G LTE smartphone