Rhino PDF dialog box slow and often not responding

Hello, I am aware of this thread and tags relating to PDF but cannot find suitable help.

…Decided to use Rhino v8 for a rudimentary survey drawing. Having issues just printing pdfs.

The print dialog window for Rhino PDF is extremely slow and in some cases resorts to “Not Responding”.

My aim is to get a pen or monochrome display type as pdf, no shadows. (Paper size A1). I realise Vector might be a big ask so even Raster is fine at this stage – but it just spins out.

Tried it on my laptop and desktop. Both Windows 10 / 11 and reasonable spec (If a bit outdated) I have also tried downloading the latest RC.

Any ideas?

I have never had an issue like this in earlier versions. Maybe I am doing something wrong?(higly likely!) Too many blocks??

thanks in advance!
Andy Kidd

Attached file
SurveyDwg3D.3dm (12.6 MB)

Hi Andypjkidd

I’ve dowloaded your file

I created named views of the plots you need
I created a layer status or your original layers
I created a layer status or original layers setup in black for printing


I created many A4 size sheets for start to check if working OK
In each A4 size sheet, I used a proper display mode in each
one YOU MUST NOT USE is the default “Monochrome” Display mode while printing in vectors (crashes Rhino)

When all went ok

I created a A1 size sheet with my custom black and white display
The one you like I think, Has noting else then black and white lines.
I did not enlarge the drawings to check 1st there will be no bug.

Finally, I created a A1 size sheet with my custom black and white display with enlarged drawings.


Hera are
Your modified File
My RUI files containing my custom black and white display called “AKT monochrome pure”

SurveyDwg3D_AKT.zip (4.3 MB)
UI.zip (566.0 KB)

Please note Display Modes are saved in the RUI file, but the Display Mode name is replaced bu a HASH
They can be retrieved in your Rhino.
PLLLLEEEEASE save your settings before !
“Tools / Export RUI Files”

Let me know if it works

Hi Karim
Thank you for looking at this. In short it did not work.

Just one thing: I cannot see a display called AKT Monochrome pure?? Maybe you called it AKT Print BW ?

I tried AK Print BW and still got the same “Not Responding screen”.

I will just have to use view capture command or something for now. Thank you for your help though!!


Rhino 8 SR2 2023-11-21 (Rhino 8, 8.2.23325.14001, Git hash:master @ f6e34187305c277ac44e974b0555f3daf930d719)
License type: Commercial, build 2023-11-21
License details: Cloud Zoo

Windows 10 (10.0.19045 SR0.0) or greater (Physical RAM: 48Gb)
.NET 7.0.0

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA Quadro M2000 (NVidia) Memory: 4GB, Driver date: 10-26-2023 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 546.01
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 10-26-2023
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Karamba\License\Karamba3D_LicensePlugin_Rhino7.rhp “Karamba3DLicense”
C:\Users\andyp\AppData\Roaming\McNeel\Rhinoceros\7.0\Plug-ins\KeyShot10RhinoPlugin (ccedd9da-83b9-429a-aec5-8ec90b85fe67)\\KeyShot10RhinoPlugin\Rhino 7\KeyShot10RhinoPlugin.rhp “KeyShot10RhinoPlugin”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V8\VRayForRhino.rhp “V-Ray for Rhino”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.2.23325.14001
C:\Program Files\Rhino 8\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 8\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino 8\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 8\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.2.23325.14001
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.2.23325.14001
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.2.23325.14001
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.2.23325.14001
C:\Program Files\Rhino 8\Plug-ins\RhinoCode\RhinoCodePlugin.rhp “RhinoCodePlugin” 8.2.23325.14001
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.2.23325.14001
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”


So sorry
I might have sent you an old RUI
Better sending Display Mode directly
called AKT Monochrome pure
Works with me

AKT Monochrome pure.ini (15.4 KB)

I’m sending you PDF prints to
pdf_prints.zip (2.2 MB)

Note :
I had to 1ST print the A4 Shade Vector PDF, for the rest to work !!!
Otherwise, the outputs were empty except for the text
There IS a bug, and actually I got many like those erratic outputs…

Rhino is Not WYSWYG…

Let me know

So it sort of works if I follow your exact process. A4 Shade Vector > then A1.
I get the same results.
The print dialogue box works much faster too, which is great!
As soon as I change the view or move the model around, I get mixed results. Best I have got so far are Raster but line-weights are out…

Many thanks for your help. I will just use Make2D for now.

Please send us a file that repeats this crash. We will try to get this fixed right away.

Thanks, I’ve added this to our bug list and will start investigating the cause of the problem

My file SurveyDwg3D.3dm If needed is in the first post on this thread.
Many thanks for looking into this issue.

I can repeat the hang (“Not responding”) issue in the Print Dialog using your file and Monochrome display mode.

This appears to be a problem with our vectorization code, but I’ll know more tomorrow… I cannot repeat the problem using other files, only your SurveyDWG file…so there is something special/unique in it that seems to be tripping up the vector output code.

I’ll let you know more once I know more.


Very interesting. Two things that come to mind:

  1. I imported and extruded from some dwgs, that are from a cad library we have here, the files of which, were drawn back in the 1990s. Normally I would never do this and always reproduce the geometry natively in Rhino.
  2. The bolts are Solidworks file imported from some where on the web.

I will try redrawing and see if it makes a difference.
Andy Kidd

Can you see if “Save as” to PDF format will improve the outcome? I find printing to PDF via Acrobat takes 10-20min, but saving to PDF is less than 30 seconds.