Rhino 7 (Mac) Continually Crashing in Perspective View

Hi all,
I am experiencing an issue where as soon as I enter perspective view and pan, Rhino immediately quits and when it reopens I see a message saying that Rhino has had an issue and had to force quit.

I’m not sure if there is any correlation but the problem began yesterday, after I accidentally opened the grasshopper plugin, which never ever works on my computer, and notoriously on most Macs. I am left faced with grasshopper loading and never reaching past 99%, only option to progress is to force quit Rhino. I am fairly suspicious that grasshopper is the cause of the issue.

I have restarted my computer, uninstalled and reinstalled the Rhino software, tried various documents, updated my Mac Software to macOS Sonoma 14.4.1 (23E224) and deleted all grasshopper files on my computer, yet the problem continues to persist. I have also tried to go into Rhino’s Package Manager, in order to remove the grasshopper plugin, but the package manager fails to load too.

My computer is 2022 M2 MacBook Pro, Running macOS Sonoma 14.4.1.

Please reach out if you have any sugguestions!

This sounds very wrong… can you please run SystemInfo in Rhino and copy/paste the results here?


Thanks for getting back to me!
SystemInfo results attatched below:

Rhino 7 SR36 2023-12-12 (Rhino 7, 7.36.23346.16352, Git hash:master @ 11a364321297eb8cdb34405a3308d8911f58706d)
License type: Educational, build 2023-12-12
License details: Cloud Zoo

Apple macOS Version 14.4.1 (Build 23E224) (Physical RAM: 8Gb)
Rhino is running in Rosetta2 on Apple Silicon
Mac Model Identifier: Mac14,7
Language: en-AU (MacOS default)

Apple M2 (OpenGL ver:4.1 Metal - 88)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: Apple
Render version: 4.1
Shading Language: 4.10
Maximum Texture size: 16384 x 16384
Z-Buffer depth: n/a
Maximum Viewport size: 16384 x 16384
Total Video Memory: 5461 MB
Graphics: Apple M2
Displays: Unknown (255dpi 2x)

Graphics processors
Apple M2
Color LCD (1440 x 900 @ 60.00Hz)

USB devices

Bluetooth devices

Third party kernel extensions

Third party plugins

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoCycles.rhp “RhinoCycles” 7.36.23346.16352
/Applications/Rhino 7.app/Contents/PlugIns/NamedSnapshots.rhp “Snapshots” 7.36.23346.1002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/GrasshopperPlugin.rhp “Grasshopper” 7.36.23346.16352
/Applications/Rhino 7.app/Contents/PlugIns/PanelingTools.rhp “PanelingTools” 7.36.23346.1002
/Applications/Rhino 7.app/Contents/PlugIns/AnimationTools.rhp “AnimationTools” 7.36.23346.1002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Commands.rhp “Commands” 7.36.23346.16352
/Applications/Rhino 7.app/Contents/Frameworks/RhMaterialEditor.framework “Renderer Development Kit” 7.36.23346.1002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RDK_EtoUI.rhp “RDK_EtoUI” 7.36.23346.16352
/Applications/Rhino 7.app/Contents/PlugIns/Displacement.rhp “Displacement” 7.36.23346.1002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoRenderCycles.rhp “Rhino Render” 7.36.23346.16352
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoDLR_Python.rhp “IronPython” 7.36.23346.16352
/Applications/Rhino 7.app/Contents/PlugIns/RhinoRender.rhp “Legacy Rhino Render” 7.36.23346.1002

Lets reset the plist…


Grasshopper plugins can be loaded from a number of places.

If you start grasshopper from the Rhino command line with GrasshopperLoadOneByOne do you see any 3rd party ones you tried to remove?

It still won’t load from there… Rhino still crashing as soon as I try to zoom, pan or rotate camera view in perspective mode!!

What plugin? I’m guessing there are residual files to clean out.