Recent WIPs Display - major slowdown with scripted EnableRedraw/DisableRedraw

script
rhinoscript

#1

Hi Steve,

Since several recent WIPs (including the latest one) the scripts that use DisableRedraw [ do things ] EnableRedraw show major slowdown compared to V5.

Try the snippet below to see it, and then remove the Disable/Enable redraw lines - then it is blazing fast as your new display engine. We have a lot of tools that rely on disabling redraw>changing view/objects etc>enabling with lots of iterations or real-time, so hope it can be fixed and they can take advantage of the new speeds!

Option Explicit
Call Main()
Sub Main()
	Dim i
	For i=0 To 50
		Call Rhino.Sleep(1)
		Rhino.EnableRedraw False
		Call Rhino.RotateCamera(, 1, 0.5)
		Rhino.EnableRedraw True
	Next
End Sub

(David Eränen) #2

Hi @Jarek,

Which viewport mode are you using? Is it the same with wireframe, shaded and rendered?

-David


#3

Hi David,

All modes are much slower compared to V5, but shaded/rendered are REALLY slow to redraw this way.

–jarek


(David Eränen) #4

Thanks @Jarek I see the problem and made this YT item: https://mcneel.myjetbrains.com/youtrack/issue/RH-39520

-David


#5

Great, thanks David (YT access for this one is not public).

–jarek


(Brian Gillespie) #6

RH-39520 is fixed in the latest WIP


#7

works well now again. thank you : )