R8 Printing Issues Continued

The raster issues are confined to certain display modes (as many already know). I spent some time playing around with combinations but can’t find any definite cause. Playing around with the DPI seems to sometimes affect the output (not consistently). Each output was using the same settings:
image image

The better looking one still has some weird line stuff going on (but is useable output none the less). Close-up the lines look like this:

The lines just aren’t printing well even when they appear a reasonable thickness.

I have a display mode based off arctic. It plots perfectly every time (so far):

For the raster issues, I think that sticking with certain display modes will side-step most the issues we’re seeing. Basically, don’t print any display mode that is (or is based off) a display mode with the silhouette line option.

Vector printing issues are a whole other matter. I haven’t had enough time to experiment yet so there may be other display modes that yield better results.

The silhouette edges area a small issue:

I was going to say that you could just set all the line thicknesses to the same, but the appears seems to be the same no matter what.

The silhouette edges appear nearly perfect within Rhino itself:

I wish it would just print like this and override the lineweights (maybe only for display modes with silhouette edges =). I hate having to go through the trouble of manually setting the “PrintDisplay” state to “ON” only to have it not actually show me what prints.

There’s also various weird quirks with Vector printing. Many of these can probably be avoided (and as mentioned I haven’t tried printing in every possible vector display mode). One of note is that if objects intersect, it affects the output, even if the object isn’t visible:

Adirondack Chair 2.3dm (12.2 MB)

I think the print width in specific modes does follow the line thickness in of the display mode:

1 Like

The pictures above are actually using identical print settings. I toggled the DPI back and forth (like from 150 to 300) and the output changed. I don’t know if it’s coincidence or what.

For now, the way to go is to avoid certain display modes if you plan to print. The arctic-based display mode is giving me the most consistent results so far. It also allows me to print paperspace elements as vector (viewports will be raster of course). Thanks for your help on that of course!!

I still haven’t figured out a way to get good vector from the viewports (viewports = detail views… 10 years of ACAD :-S… ). I might regress back to my R7 ways (2D output and stacked viewports). I should check and see if the section tools are working better. They were 98% the way there last I tested them. VARQ 3 will also have some useful tools hopefully.

1 Like

hi Keith,

since the mode you are using is a custom mode, it opens here as wireframe. Can you send me the .ini?

If I make my own technical + shaded, both 150 dpi and 300 dpi prints look the same here.

1 Like

Hi Keith -

FWIW, this is actively being worked on at this moment.

Hi Gijs,

I can attach something later if you really need it, but the modified technical just has shading and has hidden lines… hidden.

If I make my own technical + shaded, both 150 dpi and 300 dpi prints look the same here.

In other words, you’re not getting the crazy thick lines like in my example above?

Thanks for letting me know! I’ll wait until there’s updates and in the meantime just stick to what’s working (and what’s working is looking pretty alright :slight_smile: ).

I can repeat this bug and am working on it now.

1 Like

Hi @keithscadservices I put in a fix for this yesterday morning so you should get better output in the 8.4 release candidate that will be available next week. Here is an in-house build from this morning if you don’t want to wait until Tuesday for this


Thanks Steve! I’ll try this as soon as I can. Maybe tonight but probably the weekend. I appreciate all your guys’s hard work on this stuff. It will be well worth it I think because after my last round of tests I was beginning to see all the improvements from R7 shining through. The files are (usually) smaller with equal or better quality.

I did manage to try it out and so far everything is looking perfect! I could post a bunch of screen clips but I’ve loaded the forum up with quite a bit of crap recently so I’ll hold off on that.

1 Like