Question about curve output to Epilog Fusion laser cutter


We just set up an Epilog Fusion today and I have a question about “printing” to it (via the Epilog driver) from Rhino 5.

In Corel Draw, there is an option under Tools>Options>Driver Compatibility called “send beziers and paths to driver”–with this option enabled, the lasercutter head makes decidedly fluid movements when vectoring. With it disabled, the cutting head noticeably “steps” instead.

Out of the “box,” Rhino is behaving the same way as Corel does with the option disabled (definite stepping)…I don’t remember seeing this behavior in the past when was printing to an Epilog “Legend” machine.

My Epilog guys here Sweden don’t know anything about Rhino. Does anybody know an equivalent option for smooth output to the Fusion from Rhino 5?

Help Much Appreciated,

Hi Chad,

If you state that this behavior was not there in the past with an Epilog “Legend”. Can you tell what was different. Was it the same Rhino version and the same geometry? In other words, did anything else change apart from a different printer? I ask because of not; epilog’s new driver and/or new machine might lack functionality the “Legend” did have. Making this an issue of the new driver/machine rather than an issue that should be solved on Rhino’s end.

One thing to test, is to see if you have an option to control the quality of the print. Anything that is named DPI resolution fine/course could indicate a setting that will tell Rhino to increase the “resolution” of the printed.
Have a look at this post in a discussion on the quality of PDF’s printed by Rhino. It might be related:

In any case I think Steve Bear might be the guy at McNeel to have some insight on this.
@stevebaer Can you maybe shed some light on this issue?


Yes, we have 2 Legend EXT’s and we throw everything at them straight out of Rhino, no problem. They stutter a bit with REALLY dense polylines - like what happens with bad topo curves sometimes, but otherwise everything cuts clean without “stepping”. The machine only understands straight lines anyway (takes HPGL as far as I know) so it is the laser driver’s job to break this into small enough segments to do smooth curve interpolation. Have you tried feeding it different curve qualities (arcs, splines, different densities of polylines) and seeing if there’s any difference? It does sound like a driver problem to me though.

– Mitch

I’m sorry but I don’t have much to offer beyond Willem and Mitch’s comments. I know Mitch has some Epilog machines and helped me in the past with getting Rhino to properly send information to these machines. It sounds like things have changed with the new “Fusion” models and we’ll have to figure out what to do about that.

@scottd do you have contacts at Epilog that we can talk to about this?

Thank you, gentlemen, for the suggestions…upping the DPI settings in the Epilog drivers seemed to help some, but in 5mm acrylic, for example, I am still seeing coin-like ridges on discs that I do not recall ever seeing with similar files and materials on the Legend 36 EXT that I worked with in the past. After Willem’s pointing to the PDF thread, I will do some more “scientific” test cutting with output from Illustrator, Corel, and inkscape as a sanity check to see if the curves are genuinely better than straight from Rhino 5–trying different curve types as well.


If you are vector cutting, why should dpi settings matter? Dpi should only come into consideration if you are rastering, no?


Changing DPI settings does make a difference even in vector. Curves are broken down into line segments with tolerances based on resolution of the output. In the case of a computer screen that is a pixel or so; in the case of a printing it is a dot or so.

OK, but I was under the impression that it’s the laser driver that decides how something like a spline is tesselated, and that it is dpi-independent for vector cutting… May be wrong about that, have to test. All our settings are 600 dpi currently, I’ve never changed that…


OK, now I need to eat my words… just tested and the DPI setting in the driver DOES affect vector cutting. Since all of our preset materials were at 600 DPI, I never really saw any difference. But now I tested with 75, 150, 300, 600, and 1200 DPI and there is a LOT of difference, the 75 DPI is very coarsely faceted, and it gets better as you increase the value. I also see a slight difference between our standard 600 and the maximum of 1200 DPI, but not enough to make a difference for our applications.


Has there been any progress on this? We’ve been testing Rhino 5 using the latest Epilog Fusion driver and curve cutting speeds are at least 50% slower than straight line segments. There are speed and power compensation settings which help, but the movement is atrocious, including skipping around every 1/16" or so to create a curve.

Thank you!



I have still never gotten great results on curves with Rhino + Fusion; have
just been living with it…

Hmm, from your first post, what happens if you select all your curves and run “ConvertToBeziers”? Does it cut any better?