Problems with Rhino V5 latest update (11/7/2014)

Two problems with the latest V5 update (11/7/2014):

  1. You can see by the highlighted lines in the attached photo, these are 3D objects, but not all of the surfaces are showing. If I explode the item, then join it again, all surfaces then appear. The objects in the photo with the surfaces that don’t show have holes, or cutouts in them when extruded. The objects in the photo that have all surfaces visible do not have any holes, or cutouts in them.

  1. When I open the Layer Material window, the program freezes.

Can you post the file? Or a portion of it that shows the issue?

From your description I think this is an edge tolerance issue which is showing itself as missing render meshes on trimmed surfaces. You can use ExtractSrf on the the missing shaded surfaces by selecting them at the edge or an isocurve. Then use the What command to see if there is a large edge tolerance for the surface. You can use RebuildEdges to fix this and then Join again. If the render mesh is still missing, I would look closely at the surface edge to see if it is actually self-intersecting in a small loop somewhere. This can happen if the curves used were rebuilt or perhaps imported from vecotr art with errors.

Seeing the file will help determine what’s wrong… please send a screenshot of the Help menu>About Rhino page as well.


You solved it. There were self-intersecting lines in the text areas. I eliminated those, and now all the surfaces are visible. Thank you.

However, the second item in my post still remains. When I open the Layer Material window, the program freezes.

What is the current renderer, is it the default Rhino renderer or some other plug-in? Does this happen with any material or only on layers that have say textures on the material?



I am using the default Rhino renderer, but this happens when I open the Layer Material window, and click on the Color bar in the Basic Settings tab. I am just trying to assign a color to the surfaces. All the other settings are Default.


@andy, @johnc, any idea here ?


Does this happen every single time you open the layer material dialog?

  • Andy

I can’t reproduce this problem so I’m going to need some more information.

  • What operating system are you running?

  • Does this happen if you open the Layer Material dialog from an empty scene or does it require a particular document to be loaded?

  • After you click the color button, does the color picker appear before it hangs?



Andy - Yes, every time since the last update.

John -
Windows 7, 64 bit.
Just tried with two existing files, and also an empty scene, and all three froze.
The color picker does not appear. It hangs when I click the long Color: bar in the Basic Settings tab.

Sorry for the delay replying to this. Thanks for the information. I am still unable to repeat this problem, but I did encounter a similar problem which I have just fixed. It would be interesting to know if that was the same problem as this one. The next build of Rhino 5 (trunk) will have my fix for the other problem. Do you get your builds daily from Dujour? If so, please try it again with the next build (should be 11/20/2014). Thanks.


John -

I’ll try it after the next build. I don’t know what Dujour is.

OK, thanks. I am currently in the process of studying the cause of this problem so we can solve it once and for all. There are a few other scenarios in which the same issue occurs and it has become my number one priority to solve it. Thanks for your patience.

I’m glad you’ve found the problem. If possible, would you let me know when the problem is fixed so I can download the latest?

Thank you.

I believe I have found a general solution to this problem which will hopefully fix your issue. We are now in the process of extensively testing it before we can release it to ensure that it is stable. The fix will appear in the Rhino 5 SR11 Release Candidate. I’m told this should be available soon, but I can’t give you an exact date. Thanks again for your patience.


Thanks, John. Looking forward to the fix. I use that function quite a bit, so it will be good to have it work again.


Just downloaded the 12/1 update, but the above problem still exists. Maybe this update didn’t address this problem?

Version 5 SR10 64-bit
(5.10.41201.11145, 12/1/2014)


I’m afraid this fix will not appear until the Rhino 5 SR11 Release Candidate. This is because we have to test it thoroughly before we can release it. Thanks for your continued patience!